Closed Bug 1592081 Opened 5 months ago Closed 5 months ago

Near total MozMill failure on 2019-10-28

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 72.0

People

(Reporter: jorgk-bmo, Assigned: jorgk-bmo)

Details

Attachments

(1 file, 1 obsolete file)

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9277be3613ca5109ae4007a512ee75856f8f1120&tochange=0ec9e4f71228e0cdc4bcb325fe9095ede13df7d5

Running TB and clicking on a folder, doesn't show its content any more or at least not the message content. On the debug console we have:

JavaScript error: chrome://messenger/content/msgHdrView.js, line 1258: TypeError: gMessageNotificationBar is undefined

So navigation through folders is basically broken.

Too bad the firefighting is left to me alone :-( - I can't see what hit us here. I've gone back to M-C rev a670c36d436e0e9b4f4197f08095fbbe733edb53, so that's before bug 1587062 and bug 1589407.

Magnus, can you see anything? gMessageNotificationBar is defined in mail/base/content/mailWindowOverlay.js and that script should be loaded.

Hmm, taking out those bugs didn't help. Trying to start the error console gives:
JavaScript error: chrome://messenger/content/mailCore.js, line 468: ReferenceError: BrowserConsoleManager is not defined

So the likely cause is one of those DevTool bugs in the range.

Julian, do you know what's going on here?

Looks like mailWindowOverlay.js is failing do to
https://searchfox.org/comm-central/rev/95aa507b6227d1f8cfd774a625d2256478d8a9e2/mail/base/content/mailWindowOverlay.js#56

Flags: needinfo?(jdescottes)

Hmm, taking the access to BrowserConsoleManager out for the moment doesn't improve the situation.

OK, scratchpad-manager.jsm was removed, so pretty deadly to import it.

Assignee: nobody → jorgk
Attachment #9104742 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: needinfo?(jdescottes)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/656e414f2830
Port bug 1519103: Remove import of scratchpad-manager.jsm. rs=bustage-fix

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 72.0
Comment on attachment 9104759 [details] [diff] [review]
1592081-Scratchpad.patch

Review of attachment 9104759 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this is also confirmed by the first error appearing in the console:
NS_ERROR_FILE_NOT_FOUND: mailWindowOverlay.js:47
Attachment #9104759 - Flags: review+
You need to log in before you can comment on or make changes to this bug.