Closed Bug 1592136 Opened 2 years ago Closed 2 years ago

Disable LSNG (LocalStorage NextGen) in Firefox 70 release for dot release.

Categories

(Core :: Storage: localStorage & sessionStorage, task, P1)

70 Branch
task

Tracking

()

RESOLVED FIXED
Tracking Status
firefox70 blocking fixed

People

(Reporter: asuth, Assigned: janv)

References

Details

(Whiteboard: [rca - Design Error])

Attachments

(1 file)

A number of bugs have been filed since Firefox 70 release that report site breakage that's consistent with LocalStorage throwing errors. The plan is to turn off LocalStorage on release in the first available dot release.

We currently believe what we're seeing to be a mixture of 2 things:

  1. Most Common: QuotaManager storage initialization failures cascading into LocalStorage breakage.
  2. Least Common: Edge cases related to unexpected LSNG corruption that are not properly recovered from. We have at least one report where it seems that the database has 2 zeroed pages that results in a corruption error at query time but not at database open time.
  • The corruption superficially looks hardware-related, but we have not yet ruled out the possibility of improvements in browser shutdown leaving a database in an inconsistent state.

Next steps will be to add improved telemetry that can characterize the health of the LocalStorage API and what failures are happening.

I'm currently marking known manifestations of the problem as blocked by this bug.

See Also: → 1570644

There are some xpcshell-test failures, I'm looking at it right now.

Blocks: 1591777

Regarding zeroed out pages: if the "pages" are 4096 bytes long at 4096-aligned offsets, and on NTFS, then it doesn't have to be a hardware issue nor a Firefox bug. It could be a Windows issue that I have seen happen on all kinds of hardware and to all kinds of software, invariably after a dirty shutdown.

Assignee: bugmail → jvarga
Blocks: 1591684
Blocks: 1591530
Blocks: 1591517
Blocks: 1591081
Blocks: 1590804
Severity: normal → critical
Priority: -- → P1

The patch for fixing tests will be under bug 1578177.

Depends on: 1578177

(In reply to Roman from comment #4)

Regarding zeroed out pages: if the "pages" are 4096 bytes long at 4096-aligned offsets, and on NTFS, then it doesn't have to be a hardware issue nor a Firefox bug. It could be a Windows issue that I have seen happen on all kinds of hardware and to all kinds of software, invariably after a dirty shutdown.

Ok, good to know, the database page size in our case is 1024 bytes.

Comment on attachment 9104775 [details]
Bug 1592136 - Disable LSNG in 70 release. r=janv

Beta/Release Uplift Approval Request

  • User impact if declined: With LSNG enabled, QuotaManager initialization failures break LocalStorage which results in oddly broken websites for users.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1578177
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a pref disabling for a subsystem designed to support toggling the preference off. It's something we've unfortunately gotten to use several times on previous disablings and QA has tested with on/off.
  • String changes made/needed: none
Attachment #9104775 - Flags: approval-mozilla-release?
Attachment #9104775 - Flags: approval-mozilla-release? → approval-mozilla-release+

Taking this for tomorrow's 70.0.1 build.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1592897
Duplicate of this bug: 1592450
Duplicate of this bug: 1591777
Duplicate of this bug: 1591293
No longer blocks: 1591170
See Also: → 1594299

I updated to Firefox 70.0.1 yesterday. Now the website my.matterport.com fails to load properly. I checked thye same webpage on Firefox 70.0 on another Linux platform, and the webpage loads fine and functions. I believe that matterport uses dynamic Javascripts, but am not completely sure. I run Elementary OS Juno with kernel 4.15.0-66-generic.

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed
Keywords: rca-needed
Whiteboard: [rca - Design Error]
You need to log in before you can comment on or make changes to this bug.