If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot browse used cars

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
P2
major
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: James "Dexter" Akula, Assigned: Darin Fisher)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
You cannot browse used cars on Yahoo! in Netscape 7b1 or Mozilla 1.1b1.  To see
the problem, visit http://cars.yahoo.com and:

1) Pick your make from the used cars list on the right.
2) Enter your zipcode (BTW, on IE this field says ZIPCODE by default, in Mozilla
it says ZIPCO)
3) Press GO.

At this point, IE takes you to a list of cars.  Mozilla does nothing.

Comment 1

15 years ago
confirming and accepting. is not working in branch builds and trunk builds
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: nsbeta1

Updated

15 years ago
Keywords: nsbeta1

Comment 2

15 years ago
Created attachment 92650 [details]
testcase

Updated

15 years ago
Severity: minor → normal
Priority: -- → P1
Target Milestone: --- → mozilla1.2alpha

Comment 3

15 years ago
Form submission works. There are 2 redirections while processing the GET request
for the form submission. here is a brief explanation:

1st GET (the form is submitted)
IE:/autos/front/usedcars/*http://classifieds.autos.yahoo.com/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001
NS:/autos/front/usedcars/*http://classifieds.autos.yahoo.com/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001

1st 302 FOUND
LOCATION: http://classifieds.autos.yahoo.com
IE:/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001
NS:/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001

2nd GET
IE:/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001
NS:/display?ct_hft=location&action=parse&prop=automobiles&cc=automobiles&.done=http%3A%2F%2Fclassifieds.autos.yahoo.com%2Fdisplay%3Fct_hft%3Dtable%26cc%3Dautomobiles%26cs%3D-pty%2C-time%2B1%26nodeid%3D750000268%26ce_mk%3Daudi%26intl%3D-intl-%26cr%3D-dregion-%26srid%3D-dsrid-&ce_mk=audi&.csz=91001

2nd 302 FOUND 
LOCATION: http://classifieds.autos.yahoo.com
IE:/display?ct_hft=table&cc=automobiles&cs=-pty,-time+1&nodeid=750000268&ce_mk=audi&intl=us&cr=Los+Angeles&srid=375000207
NS:/display?ct_hft=table&cc=automobiles&cs=-pty,-time+1&nodeid=750000268&ce_mk=audi&intl=us&cr=Los+Angeles&srid=375000207

3rd GET
IE:/display?ct_hft=table&cc=automobiles&cs=-pty,-time+1&nodeid=750000268&ce_mk=audi&intl=us&cr=Los+Angeles&srid=375000207
NS: - DOES NOT PERFORM A 3rd GET AT ALL -

Try this:
http://classifieds.autos.yahoo.com/display?ct_hft=table&cc=automobiles&cs=-pty,-time+1&nodeid=750000268&ce_mk=audi&intl=us&cr=Los+Angeles&srid=375000207

it will return a page also in Mozilla.

Also, the server answers 2 time with 302 FOUND and we don't follow the second
redirection. (trafic captured with ethereal/winpcap)

Necko?
Assignee: alexsavulov → new-network-bugs
Status: ASSIGNED → NEW
Component: Form Submission → Networking
QA Contact: vladimire → benc

Comment 4

15 years ago
Created attachment 92662 [details]
network capture

ethereal dump file

Comment 5

15 years ago
->HTTP
Assignee: new-network-bugs → darin
Component: Networking → Networking: HTTP
QA Contact: benc → tever
(Assignee)

Updated

15 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P1 → P2

Comment 6

15 years ago
Is this related to bug 147402 in anyway?
(Assignee)

Comment 7

15 years ago
WORKSFORME linux trunk 2002083005
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Target Milestone: mozilla1.2alpha → ---

Comment 8

15 years ago
verified wfm - winNT4 09/05/02 tr

reporter, if you are still seeing this please re-open
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.