Closed Bug 1592286 Opened 2 years ago Closed 2 years ago

Investigate whether we can add hooks for the webcompat add-on to modify the position and visibility of the Picture-in-Picture toggle

Categories

(Toolkit :: Video/Audio Controls, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(2 files)

There are certain sites where the toggle interferes with elements on screen in ways that users might find jarring or unintuitive.

Our hypothesis is that we can special-case these sites using the webcompat add-ons intervention capability. We need to investigate this, and if it's possible, add the hooks necessary to do this special-casing.

Priority: -- → P3

The webcompat-addon is not only used in Firefox Desktop, but we also ship the very same code to Fennec and android-components (and the component is already enabled in Fenix), which is why development on that addon does usually not happen in m-c, but on GitHub. It's fine for patches to be submitted against m-c, but we have to keep in mind that the code has to run on more than one platform, unless this is a very short-lived experiment.

This looks fine, but could you please do us the favor of designing the experimental API in a way that just gracefully fails if the APIs in question are not there? aboutConfigPrefs.getPref(), for example, eats all exceptions and returns undefined, resulting in the addon progressing as if nothing ever happened. The other functions are async, resulting in a failed promise, but nothing more serious. pictureInPicture.getAPI() looks like it could be unhappy inside android-components the way it's currently build.

Thank you :)

Flags: needinfo?(mconley)
Assignee: nobody → mconley
Attachment #9115887 - Attachment description: Bug 1592286 - Make it possible for the WebCompat add-on to set the Picture-in-Picture toggle position. → Bug 1592286 - Add URL-mapped policy support to the Picture-in-Picture toggle. r?mstriemer
Status: NEW → ASSIGNED

That was fast! Thank you.

Flags: needinfo?(mconley)
Pushed by btara@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/38ad56dbac9b
Add URL-mapped policy support to the Picture-in-Picture toggle. r=mstriemer
https://hg.mozilla.org/mozilla-central/rev/a3701e47b259
Add a WebCompat experimental API for mapping MatchPatterns to Picture-in-Picture toggle position policies. r=denschub
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1605546
Blocks: 1608425
Blocks: 1606195
Blocks: 1610993
You need to log in before you can comment on or make changes to this bug.