Closed Bug 1592308 Opened Last month Closed Last month

Add keyboard shortcut to save and load files from the console input

Categories

(DevTools :: Console, task, P2)

task

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

This will serve as a quick workaround for people using Scratchpad.

Ctrl+O (Cmd+O on OSX) will load file content into the console input.
Ctrl+S (Cmd+S on OSX) will show the file dialog for the user
to save the console input content into a file.

A test is added to ensure this works as expected.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/21a0870c23be
Add keyboard shortcut for loading / saving from console input. r=Honza.

Ctrl+S (Cmd+S on OSX) will show the file dialog for the user

I assume that means that the open editor does not have some sense of a file being opened? So Ctrl+S to save save the buffer to the previous location without asking the user again is not possible?

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

I assume that means that the open editor does not have some sense of a file being opened? So Ctrl+S to save save the buffer to the previous location without asking the user again is not possible?

Not yet, we decided to land a simple version of import/save first. I will file a follow up bug though.

See Also: → 1593706
Duplicate of this bug: 1577898
You need to log in before you can comment on or make changes to this bug.