Closed Bug 15926 Opened 21 years ago Closed 21 years ago

Select/delete doesn't redraw properly in Location: input

Categories

(Core :: DOM: Editor, defect, P1, major)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 15901

People

(Reporter: duncan, Assigned: pavlov)

Details

Select a url in the location input, then [Delete] it.
The cursor appears at the beginning of the line, but the deleted text remains highlighted.
The text has actually been deled from the buffer, since new urls load properly.
This behaviour is 100% repeatable in the Location input.
Similar behaviour appears randomly in TEXTs and TEXTAREAs.

Linux version 2.2.9-19mdk gcc version pgcc-2.91.66 19990314 (egcs-1.1.2 release))
PentiumPro 200MHz 128MB
Mozilla M10 (BuildID 1999100808)
gtk+-1.2.3-6mdk
gtk+-devel-1.2.3-6mdk
gtk+10-1.0.6-6mdk
gtk-engines-0.5-16mdk
gtkzip-0.5-1mdk
pygtk-0.5.12-3mdk
guile-gtk-0.16-3
Assignee: don → troy
Component: Browser-General → Layout
Priority: P1
One clarification: the redraw problem only occurs if the *entire* text of the
location URL is selected and then deleted, either using the Delete or Backspace
keys or by trying to insert a character with the text selected.  Deleting a
substring isn't enough to do it.  That is, it looks like the editor is redrawing
incorrectly when a text element is entirely deleted.

I'm going to reassign this to Layout, though it might be Editor's
responsibility.  Sorry if I guessed wrong.
Assignee: troy → buster
This could be a layout bug as well, but I'm assuming it's an editor problem for
the time being
Component: Layout → Editor
QA Contact: leger → elig
Yup. This is an Ender text editing widget; QA assigning to self, and assigning to
Editor component.
Assignee: buster → pavlov
assigning to Pavlov on the same grounds that akkana assigned 15195 to him.  This
bug very well may be related to that one.
Pav, could you give me some feedback on whether these bugs are really yours or
not?  And if so, what componenet should they be assigned to? Views?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
duplicate

*** This bug has been marked as a duplicate of 15901 ***
Status: RESOLVED → VERIFIED
Verifying as duplicate.
You need to log in before you can comment on or make changes to this bug.