Closed Bug 1592649 Opened 2 years ago Closed 2 years ago

MacOS "VoiceOver" screen-reader software does not recognize "New Tab" page elements

Categories

(Firefox :: New Tab Page, defect, P3)

Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1226473
Tracking Status
firefox70 --- affected
firefox71 --- affected
firefox72 --- affected

People

(Reporter: romartin, Assigned: gsuntop)

Details

Attachments

(1 file)

Attached video VoiceOver New Tab.mov

[Affected versions]:

  • Firefox Nightly 72.0a1 Build ID: 20191030050308
  • Firefox Beta 71.0b5 Build ID: 20191028110005
  • Firefox Release 70.0 Build ID: 20191016161957

[Affected Platforms]:

  • Mac 10.14
  • Mac 10.15

[Prerequisites]:

  • Have VoiceOver opened.
  • Have the following preferences in "about:config" page:

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Open a new tab and select the "Top Sites" title.
  3. Observe the behavior.

[Expected results]:

  • The highlighted text is successfully recognized and read by the VoiceOver software.

[Actual results]:

  • The VoiceOver software does not recognize the highlighted text.

[Notes]:

  • It seems that this behavior is not specific only to "New Tab" but can also be reproduced throughout the "Firefox" browser.

Gavin, can you confirm what's up?

Flags: needinfo?(gsuntop)
Assignee: nobody → gsuntop
Flags: needinfo?(gsuntop)
Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1
Iteration: 72.2 - Nov 4 - 17 → 72.3 - Nov 18 - Dec 1

Confirmed this behavior. Looks like a systemic issue and not isolated to any particular place in New Tab. As Robert mentioned, "can also be reproduced throughout the "Firefox" browser".

Suggest that we determine a general solution and then do an audit of New Tab to get a list of necessary fixes. It may be a case of needing to change element types or add missing attributes, but may be more. Would be useful to get someone from A11Y to weigh in.

Ed - is there a different component that you'd recommend this work be explored in since it's Firefox-browser wide?

Iteration: 72.3 - Nov 18 - Dec 1 → ---
Flags: needinfo?(edilee)
Priority: P1 → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(edilee)
Resolution: --- → DUPLICATE
Duplicate of bug: 1226473
You need to log in before you can comment on or make changes to this bug.