[three dead trolls in a baggie] swf audio @ www.deadtroll.com crashes [@ libXt.so.6 + 0x22806 (0x410fc806)]

VERIFIED DUPLICATE of bug 131065

Status

()

Core
Plug-ins
P2
critical
VERIFIED DUPLICATE of bug 131065
16 years ago
16 years ago

People

(Reporter: alge, Assigned: serge (gone))

Tracking

({crash, testcase})

Trunk
mozilla1.2alpha
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA], crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Using 1.1b(2002072204)/linux, http://www.deadtroll.com/ crashes my moz. I've
disabled all plugins except java (blackdown) and flash. (they work everywhere else)

TB8647628E
(Reporter)

Comment 1

16 years ago
bz: tb: TB8647628E
libXt.so.6 + 0x22806 (0x410fc806)
libXt.so.6 + 0x22958 (0x410fc958) 

Not much, eh?
(Reporter)

Comment 3

16 years ago
WFM when disabling flash. -> plugins
Component: Browser-General → Plug-ins
Reporter: Do you use an exported X display ?
Assignee: Matti → beppe
QA Contact: asa → shrir
(Reporter)

Comment 5

16 years ago
matti: nope, local. ":0.0"
Severity: normal → critical
(Reporter)

Comment 6

16 years ago
Dupe of bug 90471?

Comment 7

16 years ago
see also bug 138786 (the crash is flash's fault)

*** This bug has been marked as a duplicate of 131065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
v
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

16 years ago
I'm reopening this to make a right dup.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

16 years ago
reporter, please try setenv DISPLAY :0, w/o srceen number.

*** This bug has been marked as a duplicate of 154427 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

16 years ago
Nope, I was wrong:( this crash is related to flash audio
<embed src="http://homepage.mac.com/deadtroll2/.Movies/trollboot.swf"
width="95%" height="95%" align="TOP" type="application/x-shockwave-flash"
play="true">
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 12

16 years ago
investigating...
Assignee: beppe → serge

Comment 13

16 years ago
serge: did you look at bug 138786?  it's the same URL.
(Assignee)

Comment 14

16 years ago
yes, I saw that bug and I saw bug 131065
and they are definitely related, but we crash on unix if flash content has an
audio in, that why I reopened it for investigation.
Here is 2 test cases one w/o audio and second w/
(Assignee)

Comment 15

16 years ago
Created attachment 92836 [details]
w/o audio
(Assignee)

Comment 16

16 years ago
Created attachment 92838 [details]
w/ audio

BTW: w/o DTD url in <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN"
both test cases seems to work
(Reporter)

Comment 17

16 years ago
The one w/o audio wfm, the one w/ crashes. Want tb?
(Assignee)

Comment 18

16 years ago
no thanks, I can see the stack trace in gdb

Comment 19

16 years ago
FWIW, when investigating bug 131065, I discovered that some swf files with audio
did not crash (although the audio is screwed up)
http://www.planettribes.com/allyourbase/AYB2.swf

the audio won't play, but Mozila will not crash.
(Reporter)

Comment 20

16 years ago
re comment #19: that URL works fine with me, audio and all.

Updated

16 years ago
Priority: -- → P2
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.2alpha

Comment 21

16 years ago
adding nsbeta1+
Keywords: nsbeta1+

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: Crash at www.deadtroll.com [three dead trolls in a baggie] → [three dead trolls in a baggie] swf audio @ www.deadtroll.com crashes [@ libXt.so.6 + 0x22806 (0x410fc806)]

Updated

16 years ago
Keywords: testcase

Comment 22

16 years ago
*** Bug 166206 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
this seems like bug 131065 (height="x%" => 0 height) + bug 90471 (flash crashes
when not shown with audio)
(Assignee)

Comment 24

16 years ago
after bug 131065 was fixed this crash is gone also,
marking this as a dup of 131065

*** This bug has been marked as a duplicate of 131065 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 25

16 years ago
reporter, can u pls verify. This does work for me, I don't crash on 0904 
build.Thx!
(Reporter)

Comment 26

16 years ago
>reporter, can u pls verify. This does work for me, I don't crash on 0904
>build.Thx!

Wow, when did Netscape hire 14-year-old Counter Strike players? (Just kidding..)

(yes, WFM, marking verified.)

K THX BYE (=
Status: RESOLVED → VERIFIED
Crash Signature: [@ libXt.so.6 + 0x22806 (0x410fc806)]
You need to log in before you can comment on or make changes to this bug.