Closed Bug 1593032 Opened 4 months ago Closed 4 months ago

IRC Bookmark shipped with Nightly has inappropriate ads

Categories

(Firefox :: Bookmarks & History, defect, P2)

72 Branch
defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.1 - Oct 21 - Nov 3
Tracking Status
firefox72 --- fixed

People

(Reporter: kwerts, Assigned: standard8)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

On Nightly: Open Bookmarks menu and click "Discuss Nightly on IRC" bookmark and wait about 6 seconds for the client to launch (or just click Launch Mibbit Client).

Actual results:

Every now and then ads similar to the attached will be shown.

Expected results:

Probably a bookmarked IRC client that doesn't have these types of ads or doesn't have ads. Kiwi IRC looks like a good candidate.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Bookmarks & History

Mike, any thoughts on what we should do here? Continuing to link to another irc instance is maybe not worth it, considering we're moving away from that.

Note these bookmarks are only added for new nightly users (or in new nightly profiles). We have a set of them intended to aid nightly users:

https://searchfox.org/mozilla-central/rev/ce02064d8afc8673cef83c92896ee873bd35e7ae/browser/locales/generic/profile/bookmarks.html.in#36-48

Flags: needinfo?(mhoye)

Internet, why are you like this.

My advice is to delete Mibbit line for now. When we stand up the new thing we can link it up then, and that's on track to be a near-term "then". For now, though, let's just clean it out.

Flags: needinfo?(mhoye)
Assignee: nobody → standard8
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 72.1 - Oct 21 - Nov 3
Points: --- → 1
Ever confirmed: true
Priority: -- → P2
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ddcb25c2e043
Remove IRC/Mibbit from the list of default bookmarks that are used in nightly builds. r=mikedeboer

Are we keeping the default IRC protocol handler, which is also mibbit (so links to irc://irc.mozilla.org/developers will open mibbit right now)? I suspect we should remove that, too... (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1528338 which we could hijack for this to keep the patches in separate bugs).

We'll also need a decision about existing profiles, where the patch as-is won't remove the bookmarks. Should we remove those, too?

Then that same question about existing profiles also applies to the protocol handler.

Flags: needinfo?(standard8)
Flags: needinfo?(mhoye)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

(In reply to :Gijs (he/him) from comment #6)

Are we keeping the default IRC protocol handler, which is also mibbit (so links to irc://irc.mozilla.org/developers will open mibbit right now)? I suspect we should remove that, too... (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1528338 which we could hijack for this to keep the patches in separate bugs).

Imo there's not a strict relation with this bug. This bookmark was suggesting users to discuss firefox nightly in a place we're pretty much deprecating for Mozilla itself. The irc protocol handler is about giving users a simpler way to use irc, it's not specifically for Mozilla discussions.

(In reply to :Gijs (he/him) from comment #6)

Are we keeping the default IRC protocol handler, which is also mibbit (so links to irc://irc.mozilla.org/developers will open mibbit right now)? I suspect we should remove that, too... (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1528338 which we could hijack for this to keep the patches in separate bugs).

As Marco said, I think that's a separate discussion. It was probably initially added to help those links work, but it isn't just for Mozilla, so maybe there should be some thought on the general requirements to keep it or not.

We'll also need a decision about existing profiles, where the patch as-is won't remove the bookmarks. Should we remove those, too?

My feeling was that for existing profiles, people will have deleted it if they don't want it, or just won't use it. If they are using it, then I'm not sure it is right to delete it from underneath them - they are obviously happy with it. I don't think we need to erase the existence of it.

For new nightly users, I think it makes sense not to "promote" it - both due to the reason described here combined with the fact that we're moving away in the short term. I did consider changing one to point to the IRC page, where users can find their own clients, but again, with IRC going away, that doesn't seem worth it at the moment.

Flags: needinfo?(standard8)

Thanks for fixing so fast!

I suggest moving the question for Mike across to bug 1528338 if you still want an answer - tracking it here for an answer there might not be best now.

Flags: needinfo?(mhoye)
You need to log in before you can comment on or make changes to this bug.