Closed Bug 1593249 Opened 3 months ago Closed 2 months ago

24.14 - 27.76% tart (linux64-shippable, macosx1014-64-shippable, windows10-64-shippable, windows7-32-shippable) regression on push f526a659b51ac9e46cb9c8abc1f685e5f9eaf372 (Tue October 29 2019)

Categories

(Firefox :: Address Bar, defect, P3)

defect
Points:
3

Tracking

()

RESOLVED WORKSFORME
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected

People

(Reporter: alexandrui, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(4 keywords)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=f526a659b51ac9e46cb9c8abc1f685e5f9eaf372

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

28% tart macosx1014-64-shippable opt e10s stylo 4.24 -> 5.42
27% tart windows10-64-shippable opt e10s stylo 2.11 -> 2.67
24% tart windows7-32-shippable opt e10s stylo 2.12 -> 2.63
24% tart linux64-shippable opt e10s stylo 1.80 -> 2.23

Improvements:

8% tart linux64-shippable-qr opt e10s stylo 3.78 -> 3.49
7% tart windows10-64-shippable-qr opt e10s stylo 2.60 -> 2.41

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=23605

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/TestEngineering/Performance/Talos

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/TestEngineering/Performance/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/TestEngineering/Performance/Talos/RegressionBugsHandling

Flags: needinfo?(mak)
Component: Performance → Address Bar
Product: Testing → Firefox
Target Milestone: mozilla72 → Firefox 72
Version: Version 3 → unspecified

Marco is away today, but all this patch did was disable the new megabar feature. If there was a regression, then it's regressed back to whatever it was before the feature was implemented. I'll see if I can find a corresponding improvement when the feature was implemented, but that might be hard since it was implemented over time and not all at once, not like how this patch disabled the feature all at once.

Blocks: megabar
Flags: needinfo?(mak)
Priority: -- → P3

we should compare these numbers once we re-enable the megabar in Nightly to get a better idea of what is shifting. If the megabar ends up being a win, that's good.

Points: --- → 3

The tart regression was balanced by an improvement now that we landed bug 1599784.

https://treeherder.mozilla.org/perf.html#/alerts?id=24255&hideDwnToInv=0

It just looks like the new design is lighter on tart.
Unless we decide to not proceed, this bug is not useful, and eventually a new perf regression would be filed if we'd disable the new design again, and then it may be worth investigating which parts of the old design make tart slower.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.