Closed Bug 1593395 Opened 3 years ago Closed 3 years ago

Remove mobile/android copy of FxAccountsWebChannel.jsm

Categories

(Firefox for Android Graveyard :: General, task, P2)

Tracking

(firefox74 fixed)

RESOLVED FIXED
Firefox 74
Tracking Status
firefox74 --- fixed

People

(Reporter: Gijs, Assigned: agi)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

https://searchfox.org/mozilla-central/rev/59de675101da711520c0bb6e34a1ea2372e7ddbb/mobile/android/chrome/content/browser.js#748-751 still seems to use it and that file has geckoview-related traces in it. On the other hand, about:accounts does things like this https://searchfox.org/mozilla-central/rev/59de675101da711520c0bb6e34a1ea2372e7ddbb/mobile/android/chrome/content/aboutAccounts.js#347 ( window.docShell.rootTreeItem.domWindow.BrowserApp.getBrowserForDocument) which implies a same-process content + parent process, which I don't think ever happens in geckoview. So not sure how much of this is dead (yet), or how best to extract it.

Priority: -- → P2
Assignee: nobody → agi
Status: NEW → ASSIGNED
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1f041f2c5c1
Remove unused FxAccountsWebChannel.jsm. r=esawin
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/00d187c3a0b0
Remove unused FxAccountsWebChannel.jsm. r=esawin
Flags: needinfo?(agi)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Product: Firefox for Android → Firefox for Android Graveyard
Duplicate of this bug: 1616635
You need to log in before you can comment on or make changes to this bug.