Closed Bug 1593446 Opened 8 months ago Closed 4 months ago

Crash in [@ mozilla::net::Http3Session::IsReused]

Categories

(Core :: Networking: HTTP, defect, P2)

72 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: alex_mayorga, Assigned: dragana)

References

Details

(Keywords: crash, nightly-community, Whiteboard: [necko-triaged])

Crash Data

Attachments

(1 file)

This bug is for crash report bp-38377a81-5e47-4e93-91e6-8a5f20191102.

Top 10 frames of crashing thread:

0 xul.dll bool mozilla::net::Http3Session::IsReused netwerk/protocol/http/Http3Session.cpp:879
1 xul.dll mozilla::net::nsHttpTransaction::Close netwerk/protocol/http/nsHttpTransaction.cpp:1042
2 xul.dll void mozilla::net::Http3Session::CloseStream netwerk/protocol/http/Http3Session.cpp:929
3 xul.dll void mozilla::net::Http3Session::CloseTransaction netwerk/protocol/http/Http3Session.cpp:918
4 xul.dll void mozilla::net::nsHttpConnectionMgr::OnMsgCancelTransaction netwerk/protocol/http/nsHttpConnectionMgr.cpp:2476
5 xul.dll nsresult mozilla::net::ConnEvent::Run netwerk/protocol/http/nsHttpConnectionMgr.cpp:258
6 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225
7 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
8 xul.dll nsresult mozilla::net::nsSocketTransportService::Run netwerk/base/nsSocketTransportService2.cpp:1010
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225

Blocks: 1581637

It seems like mConnection is null here

Flags: needinfo?(dd.mozilla)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #1)

It seems like mConnection is null here

yes, but it should not happen, I think there is another problem. I will investigate.

Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(dd.mozilla)
Priority: -- → P2
Whiteboard: [necko-triaged]

The problem is that neqo use to reset all individual streams when a ConnectionClosed has been received. That has change and it cleans up internal stream bud do not send Reset events only a StateChange(ConnectionClosed) event so necko must clean them up.

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e24517a8531a
Neqo do not reset individual streams any more, we must clean them up in necko. r=mayhemer
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hi,

I still have that problem :-(

Firefox 75.0a1 Crash Report [@ mozilla::net::Http3Session::IsReused ]
https://crash-stats.mozilla.org/report/index/49ef810b-d607-422f-87a8-0803b0200221#tab-bugzilla

Who can help me?

Thanks!

Flags: needinfo?(ncsoregi)

Hi Dragana, any chance you could chime in on this issue?

Flags: needinfo?(ncsoregi) → needinfo?(dd.mozilla)

(In reply to Wellington Torrejais da Silva from comment #7)

Hi,

I still have that problem :-(

Firefox 75.0a1 Crash Report [@ mozilla::net::Http3Session::IsReused ]
https://crash-stats.mozilla.org/report/index/49ef810b-d607-422f-87a8-0803b0200221#tab-bugzilla

Who can help me?

Thanks!

Thank you for a report.
I have open a new bug. The new bug is bug 1617142.

Status: RESOLVED → REOPENED
Flags: needinfo?(dd.mozilla)
Resolution: FIXED → ---
See Also: → 1617052
Status: REOPENED → RESOLVED
Closed: 8 months ago4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.