Closed Bug 1593602 Opened 4 months ago Closed 3 months ago

Netmonitor Search: loading indicator hidden by label overflow (macos)

Categories

(DevTools :: Netmonitor, enhancement, P3)

Unspecified
macOS
enhancement

Tracking

(firefox71 fixed, firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: jdescottes, Assigned: abowler2)

References

Details

Attachments

(3 files)

Was trying to verify a fix from Bug 1593542, and I couldn't see the loading indicator, supposed to be displayed when you perform a search. Turns out it's hidden by the textoverflow of the label that contains it.

.search-panel .status-bar-label {
  min-height: 24px;
  white-space: nowrap;
  text-overflow: ellipsis;
  display: block;
  overflow: hidden;
  min-width: 85px;
}

https://searchfox.org/mozilla-central/rev/35873cfc312a6285f54aa5e4ec2d4ab911157522/devtools/client/netmonitor/src/assets/styles/search.css#124-131

I used a slightly modified version of netmonitor that is always in status "fetching" to highlight the issue.

As you can see in the very beginning, after clicking on the search icon, the loading indicator is visible, but as soon as the mouse moves, it gets hidden and an additional ellipsis appears after the search label.

I tested on macos, not sure if this is platform specific.

FWIW I can't reproduce on Windows.

(In reply to Itiel from comment #1)

FWIW I can't reproduce on Windows.

Just to make sure: if you are on a RTL build, you need your fixes from Bug 1593542 to see the issue :)

(In reply to Julian Descottes [:jdescottes] from comment #2)

(In reply to Itiel from comment #1)

FWIW I can't reproduce on Windows.

Just to make sure: if you are on a RTL build, you need your fixes from Bug 1593542 to see the issue :)

I'm on LTR and still can't reproduce (without the patch included though, but I don't think this matters). Still on Windows.

(In reply to Itiel from comment #3)

I'm on LTR and still can't reproduce (without the patch included though, but I don't think this matters). Still on Windows.

Correct, thanks for checking. Going to mark as macos only.

OS: Unspecified → macOS
Summary: Netmonitor Search: loading indicator hidden by label overflow → Netmonitor Search: loading indicator hidden by label overflow (macos)

@Lloan, is this simple to fix?

Honza

Flags: needinfo?(lloanalas)

@Honza,

I can take a look at this and see if I can get a fix. However, if its a Mac OS issue, I have April who can help out with that as well. I'll check in a day or so.

Thanks for letting me know!

Flags: needinfo?(lloanalas)

@lloanalas and @Honza

I'd be happy to help out on this. I'll take a look and see what I can do. ~ Thanks.

(In reply to abowler2 from comment #7)

I'd be happy to help out on this. I'll take a look and see what I can do. ~ Thanks.

Awesome, thanks!
Honza

It looks as though the title is already being passed in with an ellipsis (as per the screen shot attached).

If I remove the CSS for adding the ellipsis (text-overflow, overflow, and white-space) it works as expected, but I'm not sure what effect this will have on a Windows OS.

Thanks for the analysis!

Btw. I can reproduce that on Windows at this moment

I think that text-overflow: ellipsis; should be there since it's also used for the final text that's displayed when the search finishes. This text can be quite long and doesn't have to fit the available horizontal space (when the side Search panel is narrow).

So, let's keep the ellipsis and increase the min-width of the label to 150px

https://searchfox.org/mozilla-central/rev/652014ca1183c56bc5f04daf01af180d4e50a91c/devtools/client/netmonitor/src/assets/styles/search.css#130

Please post the patch to phabricator for review
https://docs.firefox-dev.tools/contributing/code-reviews-setup.html

Honza

Assignee: nobody → abowler2
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/426df2f3f4a8
Netmonitor Search: updated min-width to keep loading indicator for being hidden, r=Honza
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9110241 [details]
Bug 1593602 - Netmonitor Search: updated min-width to keep loading indicator for being hidden, r=honza

Beta/Release Uplift Approval Request

  • User impact if declined: Searching label not fully visible
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just for developers
    Only one line CSS change
  • String changes made/needed:
Attachment #9110241 - Flags: approval-mozilla-beta?

Comment on attachment 9110241 [details]
Bug 1593602 - Netmonitor Search: updated min-width to keep loading indicator for being hidden, r=honza

Polish, uplift approved for the beta branch before RC.

Attachment #9110241 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.