downloader plug-ins, such as Download Deputy, may leave window unresponsive

RESOLVED WONTFIX

Status

()

P4
minor
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: hEADcRASH, Assigned: peterl-bugs)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a+) Gecko/20020714
BuildID:    2002071403

If you use an external downloader plug-in (such as Download Deputy), when a link
is clicked on (to be downloaded), it successfully passed off the URL, but the
browser window then becomes unresponsive. You have to hit the back button, the
same page will be displayed, but it will be, uh, responsive. :-)

The URL for the window will show the file's name, as opposed to the original
page's URL.

Reproducible: Always
Steps to Reproduce:
1. (Install a downloader plug-in, such as Download Deputy)
2. Navigate to a page that has a link to a file to download.
3. Click on the link.
4. The link is passed off correctly, but the window's contents become unresponsive.
5. Click on the back button.
6. The window is, uh, responsive.  :-)

Expected Results:  Passed off the link and remained on the original page.
(Reporter)

Comment 1

17 years ago
*** Bug 159287 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
Confirmed using FizzillaCFM/2002072203. After the download is passed over to
Download Deputy, the content area of the browser window is rendered inoperable,
including scrollbars.

It should be noted that the download URL is shown on the URL Bar. That is why
hitting "Back" results in the page working again, because you actually are
returning to the page.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Peter: should this be part of the plug-in manager work?
Assignee: beppe → peterl
Priority: -- → P4
Target Milestone: --- → mozilla1.2beta

Updated

16 years ago
Summary: Using a download manager (plug-in) leaves the original window unresponsive. → downloader plug-ins, such as Download Deputy, may leave window unresponsive

Updated

16 years ago
Target Milestone: mozilla1.2beta → mozilla1.3alpha

Comment 4

16 years ago
future
Whiteboard: [PL2:NA]
Target Milestone: mozilla1.3alpha → Future
Select radio button "open it with" and then radio button "save" will bring OK
button into active state.

Comment 6

9 years ago
I see this with Adobe Reader 9.0 on Windows XP SP3, Firefox 3.0.11. Adobe Reader is set to open in its own instance. The display for the tab from where the PDF was opened becomes unresponsive, displaying the contents of video memory from what was in that position before switching to that tab.
QA Contact: shrir → plugins
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.