Crashed when switching tabs [@ objc_msgSend]

RESOLVED DUPLICATE of bug 168719

Status

Camino Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 168719
16 years ago
16 years ago

People

(Reporter: Joe, Assigned: saari (gone))

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
Here's a crash log, I suspect relating to tabs.  I had maybe eight tabs open at
that moment and was clicking between several of them to see how it held up... ;)

This is version 0.4.0, on Mac OS X v10.1.5 with 512 MB RAM installed.

**********

Date/Time:  2002-07-24 14:22:56 -0700
OS Version: 10.1.5 (Build 5S66)

Command:    Navigator
PID:        381

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xc15f5f67

Thread 0:
 #0   0x706bab78 in objc_msgSend
 #1   0x004038bc in GetNativeData__11nsChildViewUi
 #2   0x006dff9c in GetPluginPort__19pluginInstanceOwner
 #3   0x006e018c in FixUpPluginWindow__19pluginInstanceOwner
 #4   0x006dfe70 in Notify__19pluginInstanceOwnerP8nsITimer
 #5   0x0505b080 in Fire__11nsTimerImpl
 #6   0x0505b1dc in handleTimerEvent__FP14TimerEventType
 #7   0x05056334 in PL_HandleEvent
 #8   0x0505621c in PL_ProcessPendingEvents
 #9   0x050571e4 in ProcessPendingEvents__16nsEventQueueImpl
 #10  0x0041ef34 in -[EventQueueHandler eventTimer:]
 #11  0x708d06e8 in __NSFireTimer
 #12  0x70196cbc in __CFRunLoopDoTimer
 #13  0x7017c244 in __CFRunLoopRun
 #14  0x701b70ec in CFRunLoopRunSpecific
 #15  0x7017b8cc in CFRunLoopRunInMode
 #16  0x7312d904 in RunEventLoopInModeUntilEventArrives
 #17  0x731407a4 in ReceiveNextEventCommon
 #18  0x731715fc in BlockUntilNextEventMatchingListInMode
 #19  0x70bd70b8 in _DPSNextEvent
 #20  0x70bfe5d8 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #21  0x70c23468 in -[NSApplication run]
 #22  0x70c91ed0 in NSApplicationMain
 #23  0x00004ed8 in main
 #24  0x00004d88 in _start
 #25  0x00004bb8 in start

Thread 1:
 #0   0x700252fc in select
 #1   0x0101d758 in poll
 #2   0x01019e70 in _pr_poll_with_poll
 #3   0x0015b5bc in Run__24nsSocketTransportService
 #4   0x05058da4 in Main__8nsThreadPv
 #5   0x0101b32c in _pt_root
 #6   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x01016418 in PR_WaitCondVar
 #3   0x0013c7c8 in DequeuePendingQ__12nsDNSService
 #4   0x0013c1d0 in Run__12nsDNSService
 #5   0x05058da4 in Main__8nsThreadPv
 #6   0x0101b32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x010161b4 in pt_TimedWait
 #4   0x0101642c in PR_WaitCondVar
 #5   0x0505c804 in Run__11TimerThread
 #6   0x05058da4 in Main__8nsThreadPv
 #7   0x0101b32c in _pt_root
 #8   0x7002054c in _pthread_body

Thread 4:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7086c34c in -[NSConditionLock lockWhenCondition:]
 #3   0x70ba1358 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x70842358 in forkThreadForFunction
 #5   0x7002054c in _pthread_body

Thread 7:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x01016418 in PR_WaitCondVar
 #3   0x05059ec4 in GetRequest__12nsThreadPoolP9nsIThread
 #4   0x0505a818 in Run__20nsThreadPoolRunnable
 #5   0x05058da4 in Main__8nsThreadPv
 #6   0x0101b32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 8:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body


PPC Thread State:
  srr0: 0x706bab78 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000020   lr: 0x004038bc  ctr: 0x706bab4c   mq: 0x00000000
    r0: 0xc1000000   r1: 0xbfffe8e0   r2: 0x03eba620   r3: 0x03cd8760
    r4: 0x706f7df4   r5: 0x00000001   r6: 0x02c47ed4   r7: 0x00000021
    r8: 0x00000988   r9: 0x005f5f67  r10: 0x00000020  r11: 0xff408200
   r12: 0x70400000  r13: 0x00000000  r14: 0x00000033  r15: 0x00059070
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x0005bd68  r19: 0x00001707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x7016b0c8  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0d89c00
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x87859393  r31: 0x00000001

**********

Date/Time:  2002-07-25 09:40:31 -0700
OS Version: 10.1.5 (Build 5S66)

Command:    Navigator
PID:        370

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xfffffc15

Thread 0:
 #0   0x706bab64 in objc_msgSend
 #1   0x70d91de4 in -[NSToolTipManager displayToolTip:]
 #2   0x70c3bf18 in toolTipTimerFired
 #3   0x70196cbc in __CFRunLoopDoTimer
 #4   0x7017c244 in __CFRunLoopRun
 #5   0x701b70ec in CFRunLoopRunSpecific
 #6   0x7017b8cc in CFRunLoopRunInMode
 #7   0x7312d904 in RunEventLoopInModeUntilEventArrives
 #8   0x73140818 in ReceiveNextEventCommon
 #9   0x731715fc in BlockUntilNextEventMatchingListInMode
 #10  0x70bd70b8 in _DPSNextEvent
 #11  0x70bfe5d8 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #12  0x70c23468 in -[NSApplication run]
 #13  0x70c91ed0 in NSApplicationMain
 #14  0x00004ed8 in main
 #15  0x00004d88 in _start
 #16  0x00004bb8 in start

Thread 1:
 #0   0x700252fc in select
 #1   0x0101d758 in poll
 #2   0x01019e70 in _pr_poll_with_poll
 #3   0x0015b5bc in Run__24nsSocketTransportService
 #4   0x05058da4 in Main__8nsThreadPv
 #5   0x0101b32c in _pt_root
 #6   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x01016418 in PR_WaitCondVar
 #3   0x0013c7c8 in DequeuePendingQ__12nsDNSService
 #4   0x0013c1d0 in Run__12nsDNSService
 #5   0x05058da4 in Main__8nsThreadPv
 #6   0x0101b32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x010161b4 in pt_TimedWait
 #4   0x0101642c in PR_WaitCondVar
 #5   0x0505c804 in Run__11TimerThread
 #6   0x05058da4 in Main__8nsThreadPv
 #7   0x0101b32c in _pt_root
 #8   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7086c34c in -[NSConditionLock lockWhenCondition:]
 #3   0x70ba1358 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x70842358 in forkThreadForFunction
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x01016418 in PR_WaitCondVar
 #3   0x05059ec4 in GetRequest__12nsThreadPoolP9nsIThread
 #4   0x0505a818 in Run__20nsThreadPoolRunnable
 #5   0x05058da4 in Main__8nsThreadPv
 #6   0x0101b32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body


PPC Thread State:
  srr0: 0x706bab64 srr1: 0x0200f030                vrsave: 0x00000004
   xer: 0x00000014   lr: 0x70d91de4  ctr: 0x706bab4c   mq: 0x00000000
    r0: 0x70d91de4   r1: 0xbfffee60   r2: 0x060c0124   r3: 0x0370cf10
    r4: 0x706cf85c   r5: 0x706be214   r6: 0x00000000   r7: 0x4452c000
    r8: 0x00000000   r9: 0x80bb1d28  r10: 0x44a00000  r11: 0x80b92850
   r12: 0xfffffbf5  r13: 0x00000000  r14: 0x00000033  r15: 0x0005c550
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x00063af8  r19: 0x00001707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x7016b0c8  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0d89c00
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x87859393  r31: 0x00000001

**********

Comment 1

16 years ago
Joe, for future reference, only only crash report is necessary per bug (you
quoted two). Also, crash reports should be attached to bugs as text files, and
not quoted in bug comments. Thanks.
Severity: normal → critical
Keywords: crash
(Assignee)

Comment 2

16 years ago
another copy of the plugin timer crash
->bnesse
Assignee: saari → bnesse
(Assignee)

Updated

16 years ago
Blocks: 147975

Comment 3

16 years ago
stack very similar to the one in bug 154023.  marking as dupe.  bnesse- please
reopen if it's not.

*** This bug has been marked as a duplicate of 154023 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Not certain of the bug #, but I've seen this stack in another bug... it's a dupe.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 147975

Comment 5

16 years ago
Note reporter posted two stacks. This crash probably generated the second, which
isn't plug-in related.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Summary: Crashed when switching tabs → Crashed when switching tabs [@ objc_msgSend]

Comment 6

16 years ago
See also bug 168719 and bug 173186.

Comment 7

16 years ago
Greg, I'm confused... why did you reopen this bug?

Comment 8

16 years ago
Because the reporter's comment 0 was misinterpreted. He accidentally pasted two
stacks in that comment, the first implicating pluginInstanceOwner, and the
second -[NSToolTipManager displayToolTip:]. The second, later crash is probably
the one he meant to report.

Thus, this shouldn't have been duped to bug 154023.

Comment 9

16 years ago
Oh, ok. Well then it doesn't belong to me I guess...
Assignee: bnesse → saari
Status: REOPENED → NEW
marking this as the dupe because of all the extra stack traces here that just
confuse things.

*** This bug has been marked as a duplicate of 168719 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ objc_msgSend]
You need to log in before you can comment on or make changes to this bug.