Closed Bug 1593826 Opened 4 months ago Closed 2 months ago

Control media in the cross-origin iframe by media controller after enabling Fission

Categories

(Core :: Audio/Video: Playback, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1571493
Fission Milestone M5

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 2 open bugs)

Details

After enabling Fission, the cross-origin iframe would be placed on a different process, which would result in an issue of being not able to control the media from the cross-origin iframe.

The way we use to control media is by setting the outer window's mediaSuspended state, however, when using browsing context to nofity the media action from the parent process to the cross-origin process, we always notify the top-level browsing context, which would not have the outer window because the window is in the another process.

Therefore, we should find a correct browsing context in this situation, in order to find the right window to set its state.

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Status: NEW → ASSIGNED
Fission Milestone: ? → M5

This will be fixed in bug1571493.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1571493
You need to log in before you can comment on or make changes to this bug.