Closed Bug 1593848 Opened 2 years ago Closed 2 years ago

Make XULElement getAttribute return null on non-existent attribute (matching HTMLElement)

Categories

(Core :: XUL, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 232598

People

(Reporter: bgrins, Unassigned)

References

(Blocks 2 open bugs)

Details

+++ This bug was initially created as a clone of Bug #1593303 +++

Right now if you do xulEl.getAttribute("foo") and the attribute is missing it will return "". With htmlEl.getAttribute("foo") it will return null.

There's a bunch of frontend code that relies on this behavior, so rather than having to deal with this one by one as we convert elements I think we should have an up-front change where we make XUL elements behave like HTML elements in this regard.

Duplicate of bug 232598 ? (from Mike's firefox-dev post)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232598
You need to log in before you can comment on or make changes to this bug.