Closed Bug 15942 Opened 22 years ago Closed 22 years ago

1px dark lines across page related to background image

Categories

(Core Graveyard :: GFX, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephe, Assigned: pavlov)

References

()

Details

Attachments

(3 files)

In Mozilla, the page has multiple horizontal lines that extend across the entire
page.  This page displays properly in Communicator 4.7.

Mozilla M10 on RedHat 6.1 i386
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
I don't see this problem with the latest build
Status: RESOLVED → VERIFIED
With the Oct 13th Linux Build, I don't see the problem described.
Status: VERIFIED → REOPENED
Component: Layout → Compositor
Summary: Page does not display correctly → 1px dark lines across page after scrolling
Resolution: WORKSFORME → ---
In the 10-12 Linux viewer, I see occasionall 1px horizontal lines resulting from
scrolling.  You have to scroll up and down a bit before they appear.  I think
this may be a real (compositor) bug, possibly related to bug 16200.  Reopening,
retitling, and changing component.
Assignee: troy → beard
Status: REOPENED → NEW
...and reassigning to owner of Compositor.
Status: NEW → ASSIGNED
*** Bug 16194 has been marked as a duplicate of this bug. ***
I'm seeing similar problems on http://www.abc.es/ , even without scrolling.
I, also, am still seeing the problem I originally reported.  This is in the Oct
27 build.  No scrolling is involved.  The black lines are there after the
initial display of the page.
The common thread between these pages seems to be the background image.  I have
isolated the problem in the ABC page to the background image.  I will attach the
image and a simplified test case that uses it, and a screenshot.

cc:ing pnunn, since this could be related to imagelib.  The image in this case
is 1px tall.

(Could this result from some sort of rounding error in the Compositor?  see
bug 16200)

Is this linux only or is it XP?
Summary: 1px dark lines across page after scrolling → 1px dark lines across page related to background image
I am also seeing the black lines in the original page in current builds
(yesterday's) without any scrolling.  Retitling.
The lines seem to appear in different places after partial repaints (but I think
it's always the same after full repaints).  This can be seen in the lower right
part of the attached screenshot, since a dialog box from gimp appeared over that
area before I took the screenshot.

This makes me strongly suspect a rounding problem.
The original reason I cc:ed pnunn was that I thought there was something wrong
with the image, because I thought my image viewer was acting strangely.
However, I discovered it was exhibiting normal behavior (and removed most of my
comments to that effect when I cc:ed pnunn), so the image is probably fine.
pnunn - feel free to remove yourself from the cc: list (nobody ever seems to do
that, but I think it's a sensible thing to do sometimes...).
no problem dbaron.
I don't mind the cc.
-p
Assignee: beard → pavlov
Status: ASSIGNED → NEW
it is a rounding bug.  i have a fix.
it is a rounding bug.  i have a fix.
Status: NEW → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
checked in fix
Status: RESOLVED → VERIFIED
Fixed in the Oct 1 Linux build (1999110108).
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.