checkbook.org - Incorrect year displayed

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Owen Saxton, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
The date in this page, generated by Javascript, displays the year incorrectly
(102 instead of 2002).  The problem is seen in all browsers except Internet
Explorer, so perhaps is not a direct Mozilla problem.

Comment 1

16 years ago
The site uses getYear() which is deprecated.
It should use getFullYear() instead.
This is not a bug in mozilla => Tech Evangelism.
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US General
Ever confirmed: true
OS: MacOS X → All
Product: Browser → Tech Evangelism
Hardware: Macintosh → All
Version: other → unspecified

Comment 2

16 years ago
See these bugs for further information on this issue:

bug 22964
bug 45764
bug 151912
bug 155995
Assignee: rogerl → doron
QA Contact: pschwartau → zach

Updated

16 years ago
Summary: Incorrect year displayed → checkbook.org - Incorrect year displayed

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 4

14 years ago
The date is no longer calculated with Javascript.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.