Closed Bug 1594350 Opened 5 months ago Closed 5 months ago

py-compat lint jobs has always "TypeError: the JSON object must be str, not 'bytes'" in failure summary

Categories

(Firefox Build System :: Generated Documentation, defect)

defect
Not set

Tracking

(firefox-esr68 unaffected, firefox70 unaffected, firefox71 unaffected, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: aryx, Assigned: Sylvestre)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Since bug 1593084 landed, the 'Failure Summary' tab for the py-compat job in Treeherder always lists this: TypeError: the JSON object must be str, not 'bytes'

https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=72a7829ddd116ab43289eae31825c9415c3ea0a5&selectedJob=274767234

I will have a look, sorry about that

Assignee: nobody → sledru

I renamed the json to yml, so, I don't see this error but I see:

 % ./mach lint -l py2 -l py3 -f treeherder -f json:/tmp/mozlint.json
TEST-UNEXPECTED-ERROR | /home/sylvestre/dev/mozilla/mozilla-central.hg/mozilla/ErrorList.py:1:1 | Missing from __future__ import absolute_import (require absolute_import)
TEST-UNEXPECTED-ERROR | /home/sylvestre/dev/mozilla/mozilla-central.hg/tools/docs/moztreedocs/__init__.py:5:1 | Missing from __future__ import print_function (require print_function)
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c078f40b72b1
Fix two python pycompat warnings r=ahal
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.