Closed Bug 1594427 Opened 4 months ago Closed 7 days ago

Intermittent gfx/layers/apz/test/mochitest/browser_test_group_fission.js | http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_event_region_override.html | OOPIF correctly did not scroll -

Categories

(Core :: Panning and Zooming, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone Future

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=274826286&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/LSEPxUJHRhWAkTT1YxCmCA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-11-06T14:14:58.705Z] 14:14:58 INFO - TEST-PASS | gfx/layers/apz/test/mochitest/browser_test_group_fission.js | http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_event_region_override.html | code_for_oopif_to_run successfully installed -
[task 2019-11-06T14:14:58.705Z] 14:14:58 INFO - TEST-PASS | gfx/layers/apz/test/mochitest/browser_test_group_fission.js | http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_event_region_override.html | OOPIF correctly did not get wheel event -
[task 2019-11-06T14:14:58.705Z] 14:14:58 INFO - Buffered messages finished
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/browser_test_group_fission.js | http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_event_region_override.html | OOPIF correctly did not scroll -
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - Stack trace:
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm:receiveMessage:45
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,6
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - GECKO(10360) | Finished test http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_event_region_override.html
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - GECKO(10360) | Starting test http://mochi.test:8888/browser/gfx/layers/apz/test/mochitest/helper_fission_animation_styling_in_oopif.html
[task 2019-11-06T14:14:58.706Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,4
[task 2019-11-06T14:14:58.707Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,6
[task 2019-11-06T14:14:58.707Z] 14:14:58 INFO - GECKO(10360) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\task_1573046602\appdata\local\temp\tmpawyskr.mozrunner\runtests_leaks_tab_pid9892.log
[task 2019-11-06T14:14:58.707Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,8
[task 2019-11-06T14:14:58.725Z] 14:14:58 INFO - GECKO(10360) | [Child 9892, Main Thread] WARNING: No CID found when attempting to map contract ID: file z:/build/build/src/xpcom/components/nsComponentManager.cpp, line 729
[task 2019-11-06T14:14:58.725Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,11
[task 2019-11-06T14:14:58.747Z] 14:14:58 INFO - GECKO(10360) | OOPIF got scroll to 0,14
[task 2019-11-06T14:14:58.767Z] 14:14:58 INFO - GECKO(10360) | ERROR: no embedder found in FissionTestHelperParent
[task 2019-11-06T14:14:58.768Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm, line 92: TypeError: this.embedderWindow(...) is null
[task 2019-11-06T14:14:58.768Z] 14:14:58 INFO - GECKO(10360) | [Parent 8736, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 198
[task 2019-11-06T14:14:58.768Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-11-06T14:14:58.768Z] 14:14:58 INFO - GECKO(10360) | ERROR: no embedder found in FissionTestHelperParent
[task 2019-11-06T14:14:58.769Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm, line 92: TypeError: this.embedderWindow(...) is null
[task 2019-11-06T14:14:58.769Z] 14:14:58 INFO - GECKO(10360) | [Parent 8736, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 198
[task 2019-11-06T14:14:58.769Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-11-06T14:14:58.770Z] 14:14:58 INFO - GECKO(10360) | ERROR: no embedder found in FissionTestHelperParent
[task 2019-11-06T14:14:58.770Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm, line 92: TypeError: this.embedderWindow(...) is null
[task 2019-11-06T14:14:58.770Z] 14:14:58 INFO - GECKO(10360) | [Parent 8736, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 198
[task 2019-11-06T14:14:58.770Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-11-06T14:14:58.772Z] 14:14:58 INFO - GECKO(10360) | ERROR: no embedder found in FissionTestHelperParent
[task 2019-11-06T14:14:58.774Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm, line 92: TypeError: this.embedderWindow(...) is null
[task 2019-11-06T14:14:58.774Z] 14:14:58 INFO - GECKO(10360) | [Paren--DOCSHELL 000001C072681800 == 3 [pid = 3444] [id = {f8125c8b-207e-404f-9c81-39ba3c47a54d}] [url = moz-extension://bb2d21e5-a3c9-46f1-82f8-90f174f6b7b3/_generated_background_page.html]
[task 2019-11-06T14:14:58.774Z] 14:14:58 INFO - GECKO(10360) | t 8736, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 198
[task 2019-11-06T14:14:58.774Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-11-06T14:14:58.776Z] 14:14:58 INFO - GECKO(10360) | ERROR: no embedder found in FissionTestHelperParent
[task 2019-11-06T14:14:58.776Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm, line 92: TypeError: this.embedderWindow(...) is null
[task 2019-11-06T14:14:58.776Z] 14:14:58 INFO - GECKO(10360) | [Parent 8736, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 198
[task 2019-11-06T14:14:58.776Z] 14:14:58 INFO - GECKO(10360) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-11-06T14:14:58.786Z] 14:14:58 INFO - Console message: [JavaScript Error: "TypeError: this.embedderWindow(...) is null" {file: "chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm" line: 92}]
[task 2019-11-06T14:14:58.786Z] 14:14:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]
[task 2019-11-06T14:14:58.786Z] 14:14:58 INFO - Console message: [JavaScript Error: "TypeError: this.embedderWindow(...) is null" {file: "chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm" line: 92}]
[task 2019-11-06T14:14:58.787Z] 14:14:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]
[task 2019-11-06T14:14:58.787Z] 14:14:58 INFO - Console message: [JavaScript Error: "TypeError: this.embedderWindow(...) is null" {file: "chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm" line: 92}]
[task 2019-11-06T14:14:58.787Z] 14:14:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]
[task 2019-11-06T14:14:58.787Z] 14:14:58 INFO - Console message: [JavaScript Error: "TypeError: this.embedderWindow(...) is null" {file: "chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm" line: 92}]
[task 2019-11-06T14:14:58.787Z] 14:14:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]
[task 2019-11-06T14:14:58.788Z] 14:14:58 INFO - Console message: [JavaScript Error: "TypeError: this.embedderWindow(...) is null" {file: "chrome://mochitests/content/browser/gfx/layers/apz/test/mochitest/FissionTestHelperParent.jsm" line: 92}]
[task 2019-11-06T14:14:58.788Z] 14:14:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]
[task 2019-11-06T14:14:58.788Z] 14:14:58 INFO - GECKO(10360) | [Parent 8736, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M4.1

Botond recommends that this intermittent test failure not block Fission MVP unless the failure rate exceeds the disable-recommended threshold of 30 failures/week. Last week had 19 linux64 failures out of 4867 pushes.

Fission Milestone: M4.1 → Future

(In reply to Chris Peterson [:cpeterson] from comment #5)

Last week had 19 linux64 failures out of 4867 pushes.

(Note: I expect that to decrease further, possibly to zero, given comment 3. So far there have been no failures since that fix landed.)

Going to mark this bug fixed via the landing in comment 3, since there haven't been any further failures reported.

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.