Interaction between voting and dependencies in sending email

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: dbaron, Assigned: Terry Weissman)

Tracking

unspecified
Bugzilla old
x86
Linux

Details

(Reporter)

Description

18 years ago
Email is sent at strange times for bugs with dependencies that are voted on.
The problem is that a vote does not cause email to be sent, but it does add the
voter to the cc: list (explicitly in the text used for email diffs, but not in
the bugzilla form).  However, if a dependency of the voted bug is modified, the
text for the voted bug is rebuilt to see if email should be sent.  Since the
text has changed, this causes email to be sent listing the voter as added to the
cc: list.

That is, when I voted for bug 10593 and then commented on bug 11992, the change
to bug 11992 caused mail to be sent for both bugs.

The only way I see to get around this would not be to list the voters explicitly
anywhere in the text file used for comparisons and email diffs.
Yes, this is certainly a problem.  I think, although can't prove, that I've been
added to a cc list I was on a second time because of this.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

18 years ago
Yes, you diagnosed the problem exactly.  I think I have finally fixed it.  The
email stuff is just too disgusting a hack...
per Terry, auto-verifying any resolved bug that hasn't been touched since before 
2.10 was released.
Status: RESOLVED → VERIFIED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.