Closed Bug 1594507 Opened 1 year ago Closed 11 months ago

Turning on the Omnicient Browser Toolbox breaks xpcshell-test debugging.

Categories

(DevTools :: Framework, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1576115

People

(Reporter: standard8, Unassigned)

References

(Blocks 2 open bugs)

Details

STR

  1. Set devtools.browsertoolbox.fission to true, and restart.
  2. Start an xpcshell-test which has a debugger statement with something like ./mach xpcshell-test path/to/test --jsdebugger.
  3. Go to about:debugging.
  4. Click connect, then the localhost option (you may have to add this first on a new profile).
  5. Scroll to the bottom, and select Inspect.

Expected Results

  • Debugger opens in new tab, and I can debug the test.

Actual Results

  • A new tab opens which is completely blank.

Errors recorded on the browser console:

18:31:36.840
[ACTION FAILED] REQUEST_EXTENSIONS_FAILURE: Protocol error (noAddons): This root actor has no browser addons. error-logging.js:20:17
18:31:36.842
[ACTION FAILED] REQUEST_EXTENSIONS_FAILURE should dispatch the error object! error-logging.js:21:17
18:31:38.052
Exception while opening the toolbox Protocol error (noProcesses): This root actor has no processes. Protocol error (noProcesses): This root actor has no processes.
Blocks: dt-fission
Priority: -- → P3
Whiteboard: dt-fission-reserve
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576115
Whiteboard: dt-fission-reserve
You need to log in before you can comment on or make changes to this bug.