Closed Bug 1594524 Opened 11 months ago Closed 10 months ago

Debug overlays / profiler drawing is included in GPU measurements

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: mstange, Assigned: mstange)

Details

Attachments

(1 file)

The presence of the profiler overlay is distorting the timings it displays.

We need to call end_frame before we start drawing the overlays.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/455d161a3fa9
Move the call to gpu_profile.end_frame() up so that we don't measure debug overlays. r=gw
Flags: needinfo?(mstange)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:mstange, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mstange)

I don't know if the failure was caused by this patch. This particular job only ran on two out of ~10ish pushes while the patch was on autoland, so the data is a bit thin:

Original push: 1 red + 1 green
Some later push: 1 red
Backout push: 1 green

None of the other pushes in-between (1 2 3 4 5 6 7 8 9) got any Android 8.0 Pixel2 debug wrench runs.

The green retrigger is what makes me think this was spurious. I'm going to retrigger some more.

Flags: needinfo?(mstange)

Couldn't retrigger - Wrong version of actions.json, unable to continue. I'll make a try push.

Three green wrench runs. I'm going to re-land.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/02828d8e1d78
Move the call to gpu_profile.end_frame() up so that we don't measure debug overlays. r=gw
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.