Closed Bug 159466 Opened 22 years ago Closed 20 years ago

Options under "Copies and folders" are active when they should be disabled

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: adam, Assigned: Stefan.Borggraefe)

References

Details

(Keywords: verified1.7)

Attachments

(4 files)

Moz 1.1b Build ID: 2002072104

This is kind of hard to explain.  This happens in the account manager in mail,
under Drafts and Templates in the "Copies and folder" option under any account.
 The drop-down box for the "Other" option is active when it should be disabled.
 Clicking on the radio button to activate "Other" will disable the first option.
 If you then click back to the first option everything work correctly.  This
happens each time the Mail Account manager is opened.  I will attach screenshots
to help with the explaination.
Attached image The shows what is wrong
This shows what is the problem.  The "Other" control is active when the first
option should be the only one available.
This shows what it should look like.  When the first option is selected, the
second one is disabled, and vice versa.
it's the same in Mozilla 1.1 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.1) Gecko/20020826)

if Bug#91551 (http://bugzilla.mozilla.org/show_bug.cgi?id=91551) would be done
this fixing this bug would be superfluous.
*** Bug 218438 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug persists in Mozilla build 2004020608. I checked bug 91551 but no one is
working on it.
Attached patch PatchSplinter Review
When these options were not locked the disabled attribute was removed from the
elements (after they were correctly disabled before). This is not needed and
causes the bug.

It is enough to disable the element when the option is locked and do nothing
when it is not locked.
Assignee: racham → Stefan.Borggraefe
Status: NEW → ASSIGNED
Attachment #147828 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 147828 [details] [diff] [review]
Patch

Ugh, what ugly code... cvs blames racham r=naving for making eddyk r=bhuvan
disable the radio elements separately, sigh...
Attachment #147828 - Flags: review?(neil.parkwaycc.co.uk) → review+
Severity: normal → trivial
OS: Windows XP → All
Hardware: PC → All
Attachment #147828 - Flags: superreview?(bienvenu)
Just to give you an idea of the sort of cleanup that should be possible...

Note that I've only done basic testing with this to ensure that the right
things get selected and enable/disable as you switch panels and accounts.
Attachment #147828 - Flags: superreview?(bienvenu) → superreview+
This bug is fixed. I filed bug 243084 for additional cleanup of am-copies.js.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Comment on attachment 147828 [details] [diff] [review]
Patch

Asking for approval. This patch makes sure that the UI elements of the "Copies
& Folders" pane are correctly disabled. Very low risk.
Attachment #147828 - Flags: approval1.7?
Comment on attachment 147828 [details] [diff] [review]
Patch

a=chofmann for 1.7
Attachment #147828 - Flags: approval1.7? → approval1.7+
Keywords: fixed1.7
Verified as fix on latest 1.7 branch 06-18 build.
Changing keywords from fixed1.7 to verified1.7.
Leave this bug status "as is" until this bug be verified on trunk again...
Keywords: fixed1.7verified1.7
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: