Images on local pages load regardless of pref setting

RESOLVED DUPLICATE of bug 64068

Status

()

RESOLVED DUPLICATE of bug 64068
17 years ago
16 years ago

People

(Reporter: mpaugh, Assigned: morse)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

If I set in the preferences "Do not load any images" and then load an HTML page
that's on a local drive, the images load anyway.  I assume this is by design
(although if you ask me it's very contradictory, since "do not load any images"
should mean just what it says), but there are two problems/bugs regarding this:

1) This makes testing pages using Mozilla essentially impossible because there
is no way to see what my page looks like without images.  (I have to
purposefully break all of my image links, upload to a temporary remote site, or
use another browser, if I want to see what a remote visitor would see if they
don't have image loading on, or if they are using a text-only browser.)

2) More critically: remote images on local pages get loaded regardless of the
settings in the preferences dialog.  In other words, say I open a local HTML
file that has an image link with a SRC set to something like
"http://www.remote.com/image.gif"...my computer will then attempt to open an
internet connection (if I don't have one open already) and download the image. 
Even though I have image loading turned off!  (This also has a few potential
security/privacy ramifications.)

Reproducible: Always
Steps to Reproduce:
1. Turn images off.
2. Open a local HTML page, preferably one with a remote image (web rings are
good for this).

Actual Results:  Images are loaded anyway.

Expected Results:  Do not (automatically) load any images whatsoever if "Do not
load any images" is selected.  At the very least, do not load remote images
along with local images.
-> Image Blocking (?)
Assignee: Matti → morse
Component: Browser-General → Image Blocking
QA Contact: asa → tever

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 64068 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: tever → nobody
You need to log in before you can comment on or make changes to this bug.