Closed Bug 1594735 Opened 3 months ago Closed 3 months ago

test-android-em-7.0-x86_64/opt-geckoview-xpcshell-e10s-1 is perma-fail under new packet deployment

Categories

(GeckoView :: General, defect, P1, blocker)

x86_64
Linux
defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: wcosta, Assigned: gbrown)

References

Details

(Whiteboard: [geckoview]?)

Attachments

(1 file)

As Nov. 9, Taskcluster will switch deployment to firefox-ci, and packet.net machines will be upgraded to Ubuntu 18.04.

The test test-android-em-7.0-x86_64/opt-geckoview-xpcshell-e10s-1 doesn't work under this new deployment.

Component: Testing → General
Product: Firefox for Android → GeckoView

(In reply to Wander Lairson Costa [:wcosta] from comment #0)

The test test-android-em-7.0-x86_64/opt-geckoview-xpcshell-e10s-1 doesn't work under this new deployment.

That log has 2 failures:

[task 2019-11-07T14:04:18.416Z] 14:04:18 WARNING - TEST-UNEXPECTED-FAIL | dom/presentation/tests/xpcshell/test_presentation_session_transport.js | xpcshell return code: 0

[task 2019-11-07T14:09:21.400Z] 14:09:21 WARNING - TEST-UNEXPECTED-TIMEOUT | dom/presentation/tests/xpcshell/test_tcp_control_channel.js | Test timed out

Both of those tests are already failing intermittently on Android.

See Also: → 1422582, 1555323

Geoff, does this look like a GeckoView bug or a test runner or infra problem on Packet?

Flags: needinfo?(gbrown)
Whiteboard: [geckoview]?

I'm not sure where the problem is. I don't think there's reason to suspect the test runner or harness - lots of other tests seem to be running fine.

I'm tempted to say infra since the perma-fail starts with the new deployment (which incidentally is curious, since the test is running in an emulator in a docker image...how is the host os having an effect?), but since these tests are already failing intermittently, maybe the new deployment is just changing timing or something, triggering a more persistent failure? Failures seem to be android/geckoview-specific, so maybe it's geckoview?

Flags: needinfo?(gbrown)

Today X1 is not perma-fail but does fail frequently. X2 also has a high rate of failure. Several tests seem to be involved.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=c6f3db433f5e6c6788bd999b4a643e73cc5eff09

Recall that the last time the android emulator was upgraded, we continued to use the older version for xpcshell because of bug 1568063.

I tried upgrading now:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e5e14c7b207a6f933615220cd5bf3b278ac8abd8

and all of the failures seen in this bug seem to have disappeared. However, bug 1568063 still occurs (only 1 failure in 120 tasks in this try push).

Just a heads up that the new deployment upgrades Ubuntu from 14.04 to 18.04.

Assignee: nobody → gbrown

Upgrade the emulator used by xpcshell tests to 29.2.1, the same version used
by all other android tests.
We have delayed this upgrade because of intermittent failures seen on the new
emulator not seen previously - bug 1568063. After the packet.net upgrade to
Ubuntu 18.04, try runs with the new emulator show that bug 1568063 persists
but has less impact than the intermittent failures it resolves: More tests
pass consistently with the new emulator than with the old.

Regressions: 1568063
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a65a260a14fe
Upgrade android emulator used for x86_64 xpcshell tests; r=aerickson
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.