Dropdown lists do not show correctly

RESOLVED DUPLICATE of bug 154670

Status

()

RESOLVED DUPLICATE of bug 154670
17 years ago
16 years ago

People

(Reporter: griswold, Assigned: rods)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020724
BuildID:    2002072422

When I click on one of the two dropdown lists on the left side of the page,
usually nothing happens.  Occasionally, the list will flash briefly then
disappear.  After I select the list, I can scroll through the list contents
using the up and down arrows.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.opensecrets.org/industries/indus.asp?Ind=B12.
2. Try to see the contents of one of the dropdown lists by clicking on it or on
the down arrow next to the list.
3. Nothing happens, or the list only appears briefly.

Actual Results:  List doesn't open or only appears briefly.

Expected Results:  The list should drop down to show the contents.

This works on Netscape 4.79 and Mozilla 1.0.  It doesn't work in 1.1a, build
2002071522, or build 2002072422.
(Reporter)

Comment 1

17 years ago
After reading my comments, I notice that they aren't as clear as they could be.
 After selecting the list, I can scroll through the list contents using the up
and down arrow keys on the keyboard.  In step 2 of the steps to reproduce, the
down arrow I refer to is the glyph to the right of the currently selected item
in the list.

I checked the page source, and it looks like the site uses JavaScript.  This may
be a JavaScript issue, since I don't see this problem in sites that don't use
JavaScript.

Comment 2

16 years ago
I'm using linux nightly 2002120705. I can reproduce this.

The two drop-down selectors are each rows in a table. Every row in the table has
applied to it:

    class="nav"
    onMouseOver="this.className='navhilite';"
    onMouseOut="this.className='nav';"

I.e. a different class is applied to the row while the mouse is over it.

When the user clicks the mouse on a selector, the OnMouseOut event fires for the
row. The selector also opens. Then the user moves his mouse (to select
something) and OnMouseOver triggers again. The CSS change probably causes the
selector to close.

OnMouseOut triggering on click is a known problem; see bug 132592. Selectors
closing on CSS events is also a known problem; see bug 154670.

*** This bug has been marked as a duplicate of 154670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.