Closed Bug 1594875 Opened 2 years ago Closed 2 years ago

Add support to manipulate the compose message HTML

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1630786

People

(Reporter: _+bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I tried to create a WebExtension for Thunderbird that changes the new message HTML before the user starts typing in it. It should add a custom CSS style to every composed message, including replies and forwards. This feature was provided by the now dead and in the future unsupported Stationery add-on.

Actual results:

I read the docs: https://thunderbird-webextensions.readthedocs.io/en/68/

It doesn't contain anything about this feature. So I assume it's not possible. This is the first feature I'm looking for regarding Thunderbird add-on development. So for now this is a 0% support rate for existing add-ons' features.

I fear the day when Thunderbird 78 will break everything I was used to and that made me more productive. Maybe I'll finally switch to a web-based MUA by then.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1630786
You need to log in before you can comment on or make changes to this bug.