Closed Bug 1594885 Opened 5 months ago Closed 5 months ago

What's New in DevTools Panel in Firefox 71

Categories

(DevTools :: General, enhancement, P1)

All
Unspecified
enhancement

Tracking

(relnote-firefox -, firefox71+ verified, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
relnote-firefox --- -
firefox71 + verified
firefox72 --- verified

People

(Reporter: Harald, Assigned: jlast)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Ship a basic What's New Panel in Firefox 71.

Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Keywords: meta
Summary: [meta] What's New in DevTools Panel in Firefox 71 → What's New in DevTools Panel in Firefox 71

Passing by note: this can't really be targeting 71 (current beta), since it requires new content (i.e. new strings).

:flod, to ship this English-only should we avoid using strings?

(In reply to :Harald Kirschner :digitarald from comment #3)

:flod, to ship this English-only should we avoid using strings?

Correct, either hardcode the messages, or put the localization file in a path that is not exposed for localization. From a quick look at the current WIP patch, you'll need both.

I would argue that this should be displayed only to en-* users if untranslated, because it's going to provide a subpar experience for users with a fully localized build. If order for this content to be localized, it should land in mozilla-central before the version gets uplifted to mozilla-beta.

(In reply to Francesco Lodolo [:flod] from comment #4)

(In reply to :Harald Kirschner :digitarald from comment #3)

:flod, to ship this English-only should we avoid using strings?

Correct, either hardcode the messages, or put the localization file in a path that is not exposed for localization. From a quick look at the current WIP patch, you'll need both.

I would argue that this should be displayed only to en-* users if untranslated, because it's going to provide a subpar experience for users with a fully localized build. If order for this content to be localized, it should land in mozilla-central before the version gets uplifted to mozilla-beta.

AFAIK, the plan so far was to propose this feature to en-* users only.

Correct, either hardcode the messages, or put the localization file in a path that is not exposed for localization. From a quick look at the current WIP patch, you'll need both.

Jason, fyi.

Flags: needinfo?(jlaster)

We can hardcode all messages, there's no need to have .properties entries for the panel definition strings AFAIK.

Flags: needinfo?(jlaster)

Hi Pike,

We would like to show this panel only to english users. From a code perspective do you have a suggestion on how to detect that?

Flags: needinfo?(l10n)

I think checking the following should work:

Services.locale.negotiateLanguages(['en'], [Services.locale.appLocaleAsBCP47]).length

If Services.locale.appLocaleAsBCP47 is en-*, this results in 1, otherwise 0.

Flags: needinfo?(l10n)

(In reply to Axel Hecht [:Pike] from comment #9)

I think checking the following should work:

Services.locale.negotiateLanguages(['en'], [Services.locale.appLocaleAsBCP47]).length

If Services.locale.appLocaleAsBCP47 is en-*, this results in 1, otherwise 0.

Thanks!

No longer blocks: 1596037
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1fb9356c0a94
Basic scaffolding for whatsnew panel in DevTools r=jlast,nchevobbe

Backed out changeset 1fb9356c0a94 (bug 1594885) for devtools failures at browser_toolbox_tools_per_toolbox_registration.js on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/697506c8c54e4a01e1355fbf967b9a52bd656f6e

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=1fb9356c0a94cc9af715fd0ffd9fc21796029628&selectedJob=276106040

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=276106040&repo=autoland&lineNumber=2689

Log snippet:

[task 2019-11-14T00:34:00.114Z] 00:34:00 INFO - TEST-START | devtools/client/framework/test/browser_toolbox_tools_per_toolbox_registration.js
[task 2019-11-14T00:34:02.614Z] 00:34:02 INFO - GECKO(1894) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-11-14T00:34:02.614Z] 00:34:02 INFO - GECKO(1894) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2019-11-14T00:34:02.784Z] 00:34:02 INFO - TEST-INFO | started process screentopng
[task 2019-11-14T00:34:03.193Z] 00:34:03 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-14T00:34:03.194Z] 00:34:03 INFO - Buffered messages logged at 00:34:00
[task 2019-11-14T00:34:03.194Z] 00:34:03 INFO - Adding a new tab with URL: data:text/html,<!DOCTYPE html>
[task 2019-11-14T00:34:03.195Z] 00:34:03 INFO - <html>
[task 2019-11-14T00:34:03.195Z] 00:34:03 INFO - <head>
[task 2019-11-14T00:34:03.196Z] 00:34:03 INFO - <meta charset="utf-8">
[task 2019-11-14T00:34:03.196Z] 00:34:03 INFO - </head>
[task 2019-11-14T00:34:03.196Z] 00:34:03 INFO - <body>
[task 2019-11-14T00:34:03.197Z] 00:34:03 INFO - test for registering and unregistering tools to a specific toolbox
[task 2019-11-14T00:34:03.197Z] 00:34:03 INFO - </body>
[task 2019-11-14T00:34:03.197Z] 00:34:03 INFO - </html>
[task 2019-11-14T00:34:03.198Z] 00:34:03 INFO - Tab added and finished loading
[task 2019-11-14T00:34:03.198Z] 00:34:03 INFO - Buffered messages logged at 00:34:01
[task 2019-11-14T00:34:03.199Z] 00:34:03 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-11-14T00:34:03.199Z] 00:34:03 INFO - Buffered messages logged at 00:34:02
[task 2019-11-14T00:34:03.200Z] 00:34:03 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-11-14T00:34:03.200Z] 00:34:03 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-11-14T00:34:03.201Z] 00:34:03 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-11-14T00:34:03.202Z] 00:34:03 INFO - add per-toolbox tool in the opened toolbox.
[task 2019-11-14T00:34:03.202Z] 00:34:03 INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_tools_per_toolbox_registration.js | per-toolbox tool is not registered globally -
[task 2019-11-14T00:34:03.202Z] 00:34:03 INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_tools_per_toolbox_registration.js | per-toolbox tool registered to the specific toolbox -
[task 2019-11-14T00:34:03.203Z] 00:34:03 INFO - Buffered messages finished
[task 2019-11-14T00:34:03.203Z] 00:34:03 INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_toolbox_tools_per_toolbox_registration.js | new tool's tab exists in toolbox UI -
[task 2019-11-14T00:34:03.203Z] 00:34:03 INFO - Stack trace:
[task 2019-11-14T00:34:03.203Z] 00:34:03 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2019-11-14T00:34:03.204Z] 00:34:03 INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_toolbox_tools_per_toolbox_registration.js:testToolRegistered:81

Flags: needinfo?(jlaster)
Attachment #9108215 - Attachment is obsolete: true
See Also: → 1596345
Attachment #9108215 - Attachment is obsolete: false
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d87213b99f46
Basic scaffolding for whatsnew panel in DevTools r=jlast,nchevobbe
https://hg.mozilla.org/integration/autoland/rev/ab5f80e64f58
What's New in DevTools Panel in Firefox 71. r=jdescottes,victoria
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9108215 [details]
Bug 1594885 - Basic scaffolding for whatsnew panel in DevTools

Beta/Release Uplift Approval Request

  • User impact if declined: The whats new panel is a new panel that highlights new features introduced in devtools. Users in 71 will not have an easy way to find out about the new features.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a devtools panel and only visible to users who open devtools. The panel does not affect behavior in devtools.
  • String changes made/needed: The patch adds new strings that are not going to be localized, since the functionality will only be available to users in the English locale.
Flags: needinfo?(jlaster)
Attachment #9108215 - Flags: approval-mozilla-beta?
Attachment #9107635 - Flags: approval-mozilla-beta?

Release Note Request (optional, but appreciated)
[Why is this notable]: often requested feature by users
[Affects Firefox for Android]: no
[Suggested wording]: Developer Tools now have a "what's new" panel that informs you about the latest DevTools features and provides helpful tips for smarter debugging.
[Links (documentation, blog post, etc)]: in a way, this is its own blog post.

relnote-firefox: --- → ?

Just cherry-picked the two commits onto beta

The first commit has two merge conflicts with this property in toolkit/components/telemetry/Events.yaml. Here is how I merged it

    objects: ["accessibility", "application", "dom", "inspector", "jsdebugger", "memory", "netmonitor", "options", "performance", "scratchpad", "storage", "styleeditor", "webconsole", "whatsnew","other", "fakeTool4242", "testBlankPanel", "testTool", "testtool1", "testTool1072208", "testtool2"]

Let me know if you have any questions or if there is something I can do to help

Bug 1594885 should be uplifted as well as only identified major issue.

Comment on attachment 9108215 [details]
Bug 1594885 - Basic scaffolding for whatsnew panel in DevTools

Feature uplift approved via a release exception request, uplift approved for 71 beta 11, thanks.

Attachment #9108215 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9107635 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Regressions: 1597229

Verified with 71.0b11 and 72.0a1 (2019-11-17).

Status: RESOLVED → VERIFIED
Hardware: Unspecified → All

Not in the general release notes as this is en-* + devtools only and it is by itself a release note.

You need to log in before you can comment on or make changes to this bug.