No images in print preview

CLOSED WORKSFORME

Status

()

CLOSED WORKSFORME
17 years ago
16 years ago

People

(Reporter: baphomepage, Assigned: rods)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020618
Netscape/7.0b1
BuildID:    2002061104

When i ask 4 a printpreview of a html document, it doesn't show images.

Reproducible: Always
Steps to Reproduce:
1.Open URL
2.Print Preview


Actual Results:  Images are not shown in Printpreview

Expected Results:  Showed images.

In trying to make my website compatible to Mozilla and Netscape i had the
following problem. I guess it's a bug. I uploaded some especially for bugzilla,
so no links are working yet. Netscape 7 has the same problem.

--------- THE PROBLEM -------
Mind that it is correct that you don't see the left column in printpreview, it
is exluded by a style-sheet (MEDIA). The guy you see however should be visable
in printpreview. I tried to understand the problem, i think i got it:

The images are not shown if they either miss HEIGHT or WIDTH within <img> -tag

I also uploaded another file:
http://members.fortunecity.com/hounou/coster/noproblem.html
In this page the img-tag (of the picture of the guy again) has both HEIGHT and
WIDTH. Try this one and you see it's working just fine!

As far as i know the height and width are not obliged by HTML 4.01, are they?

Comment 1

17 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020722

Reporter, please try an actual Mozilla-Build!
(Reporter)

Comment 2

17 years ago
Ohh sorry I did, i reported this message with Netscape.
The Mozillaversion i used is:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
Build ID: 2002061104

It's the Mozilla 1.1a, i downloaded from mozila.org
(i also got netscape 7 preview release installed, same problem, see User-Agent
of my first post)

Comment 3

17 years ago
I tried with 1.0.0, WFM too.
Might be a Problem with your profile (I am no expert for that)?  Could you
create a new profile for test- affairs and check again?

Comment 4

17 years ago
Experiencing a similar problem under Linux -- print preview seems to work but
images won't print to paper or to postscript file.  The bug seems somewhat
fickle, printing the same page over and over again will sometimes get one or two
images, but never all the images (for example, www.ximian.com).

I can verify that creating a new profile fixes the problem, but that is a no-go
unless I can migrate all my mail, password settings, etc to the new profile,
which I have been unable to do without either reintroducing the problem or
without getting the functionality I require.  Any ideas or hints on which file
in the directory might be causing this behavior?   

Comment 5

17 years ago
This seems to be a cache consistency problem.  If I select
Preferences->Advanced->Cache->clear (memory&disk) cache, close the browser,
manually delete everything in .mozilla/usr/xxx/Cache, then restart, printing
works again.
(Assignee)

Comment 6

17 years ago
This is a dup and a known issue. You can't clear your cache and then try to do
PP for an existing page.
Whiteboard: DUPME
Is this still an issue?

Comment 8

16 years ago
I tired to recreate the bug using the Mozilla (version 1.4b (Gecko build. 
20030416)) on the Microsoft Windows XP (NT build 5.1 (build no. 2600)) (with 
Service pack 1) platform and Mozilla works as expected, the bug was not 
apparant. I tired on several casses in print preview but the bug could not be 
duplicated.
Simon Pang

Comment 9

16 years ago
Of the comment above, I usually clean my cache every week.
Simon Pang

Comment 10

16 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030420

Comment 11

16 years ago
WFM too with Build 2003042904 and Windows XP. 

Marking WFM. Please reopen if you can reproduce it with a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPME
(Reporter)

Comment 12

16 years ago
Sorry that i haven't comment for a while. I seems that the problem has been
solved indeed. Great work guys! (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b)
Gecko/20030210)

I'll delete the files from the server again.

TANX!
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.