Closed Bug 1594992 Opened 2 years ago Closed 2 years ago

"+ Add to Firefox" button on Recommended Extensions page does nothing

Categories

(Toolkit :: Add-ons Manager, defect)

70 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1583665
Tracking Status
firefox70 --- affected
firefox71 --- unaffected
firefox72 --- unaffected

People

(Reporter: sheelgautam995, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Attached video Recording.mp4

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:70.0) Gecko/20100101 Firefox/70.0

Expected results:

The button should install the extension

Summary: "+ Add to Firefox" button does nothing on Recommended Extensions page → "+ Add to Firefox" button on Recommended Extensions page does nothing
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Does installing extensions from https://addons.mozilla.org/ work?

Flags: needinfo?(sheelgautam995)

Yes

Flags: needinfo?(sheelgautam995)

This sounds kinda bad but we can't reproduce. Krupa, could you take a look?

Flags: needinfo?(kraj)

On Firefox 70, with all the add-ons the reporter has installed, I wasn't able to reproduce the issue.

@sheelgautam995, do you see any errors in your browser console?

NIing alexa to do some exploratory testing to see if she can trigger this error.

Flags: needinfo?(alexandra.moga)

I've discovered that Addons install when browser window is not in fullscreen mode on MacOS.
When browser window is in fullscreen mode, the button do nothing.

I don't see anything important in the browser console. But, I've discovered an interesting bug in the browser console which I will submit separately.

Hello,

I have managed to reproduce the issue consistently on Windows 10 Pro 64-bit, MacOS Catalina 10.15 and Ubuntu 16 on the latest Release version (70.0.1/20191030021342) exclusively, with the following STR:

  1. Start the browser and enter fullscreen mode (F11 on Win and Ubuntu / Green Expand Icon or Control+Command+F on MacOS)
  2. Go to Add-ons Manager page and click the “+Add to Firefox” button or “+ Install Theme” of any extension or theme from either the “Recommendations”, “Extensions” or “Themes” tabs.

Actual results:
Add-ons are not installed and themes are neither. No errors are displayed in the console.

AMO installation works fine under fullscreen mode on all OSes.

The latest Nightly and Beta are unaffected by this i.e add-ons and themes can be properly installed in fullscreen mode, both from add-ons manager and AMO.

The issue might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1583665 .

Status: UNCONFIRMED → NEW
Ever confirmed: true

This seems to work for me on Nightly in fullscreen mode. Sounds like a dupe of bug 1583665 then.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1583665
Flags: needinfo?(kraj)
You need to log in before you can comment on or make changes to this bug.