Closed Bug 1595029 Opened Last month Closed Last month

Search text from the search bar in Customize menu is not centered

Categories

(Firefox :: Toolbars and Customization, defect, P3)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- verified
firefox72 --- verified

People

(Reporter: atrif, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image macOS_search.png

Affected versions

  • 71.0b8 (20191107101713)
  • 72.0a1 (20191107215315)

Affected platforms

  • macOS 10.14
  • macOS 10.10

Steps to reproduce

  1. Open Firefox and go to Customize Menu.
  2. Observe the Search item.

Expected result

  • Centered text on the Search bar inside the Customize menu.

Actual result

  • Search text inside Search bar is not centered.

Regression range

Additional Notes

  • Attached a screenshot on Windows and macOS with the issue.
  • Ubuntu is not affected.
Attached image windows search.png

This is how it looks on Windows10 x64.

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(ntim.bugs)
Priority: -- → P3
Regressed by: 1534455

The placeholder text used to be hidden within the customize mode using:

toolbarpaletteitem > toolbaritem > textbox > moz-input-box > html|*.textbox-input {
  visibility: hidden;
}

in textbox.css, but that rule stopped applying with bug 1534455 and bug 1513325 removed it.

Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Summary: [macOS] Search text from the search bar in Customize menu is not centered → Search text from the search bar in Customize menu is not centered

Comment on attachment 9107567 [details]
Bug 1595029 - Hide searchbar placeholder text in customize mode. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: "Search" placeholder text is wrongly in searchbar in customize mode
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0, the placeholder text should be hidden like it was before.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Straightforward CSS fix
  • String changes made/needed: none
Attachment #9107567 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/02b02d679df2
Hide searchbar placeholder text in customize mode. r=Gijs
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9107567 [details]
Bug 1595029 - Hide searchbar placeholder text in customize mode. r=Gijs

One line CSS fix for visual polish, looks safe for beta, uplift approved for 71 beta 9, thanks.

Attachment #9107567 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hello!
The issue is verified fixed with Firefox 72.0a1 (20191111215252) and Firefox 71.0b9 (20191111170815) on Windows 10x64, macOS 10.14 and Ubuntu 18.04. No text is shown on the "Search bar" item in Customize mode.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.