Closed Bug 1595063 Opened 1 year ago Closed 1 year ago

Update AttributionCode.jsm to handle user agent

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 73
Iteration:
73.2 - Dec 16 - Jan 5
Tracking Status
firefox73 --- verified

People

(Reporter: andreio, Assigned: Mardak)

References

Details

Attachments

(3 files)

Update AttributionCode to handle new attribution data for browser name and version.

Assignee: nobody → andrei.br92
Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1
Iteration: 72.2 - Nov 4 - 17 → 72.3 - Nov 18 - Dec 1
Assignee: andrei.br92 → nobody
Iteration: 72.3 - Nov 18 - Dec 1 → 73.1 - Dec 2 - Dec 15
Assignee: nobody → andrei.br92

This will be needed for a long-term solution of passing around the UA, but the initial approach suggested in bug 1406005 comment 44 seems to suggest using the existing experiment and variation params for now, so this might not be P1 anymore.

See Also: → 1406005
Iteration: 73.1 - Dec 2 - Dec 15 → 73.2 - Dec 16 - Jan 5

I'll take the original patch from https://github.com/mozilla/activity-stream/pull/5372 and update it to handle "ua" giving flexibility of bedrock/stubattribution to pass in the raw UA or somewhat parsed/filtered or other value.

Assignee: andrei.br92 → edilee
Summary: Update AttributionCode.jsm to handle browser name and version → Update AttributionCode.jsm to handle user agent

Add "ua" and increase allowed length for attribution codes. Allows asrouter devtools to set all keys.

hoosteeno, should you (or maybe jimt?) fill out the data collection request as what was done for experiment/variation in bug 1515172 comment 4 (and original bug 1292360 comment 19)? The attribution data will be set via bedrock as usual.

Flags: needinfo?(hoosteeno)
See Also: → 1292360, 1515172

I think JimT should do that.

Flags: needinfo?(hoosteeno) → needinfo?(jimthomas)

This is the first data-review I've done so apologies if I missed anything. Please redirect if needed, thanks!

Flags: needinfo?(jimthomas)
Attachment #9117590 - Flags: data-review?(chutten)
Comment on attachment 9117590 [details]
Data Collection Review Form

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is documented in the [in-tree documentation](https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/data/environment.html).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Jim Thomas is responsible.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.

---
Result: datareview+
Attachment #9117590 - Flags: data-review?(chutten) → data-review+
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/325f8606c0c1
Support user agent attribution codes r=mixedpuppy,nanj
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

:chutten, just to clarify, does this data review cover the various steps in the pipeline of logging this UA data? The UA strings will be captured on the webiste by the bedrock team, passed through the installer and then into desktop telemetry. Is that all covered by this review or do you need any other details?

(In reply to Chris H-C :chutten from comment #7)

Comment on attachment 9117590 [details]
Data Collection Review Form

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for

the ultimate data set available publicly, complete and accurate?

Yes. This collection is documented in the [in-tree
documentation](https://firefox-source-docs.mozilla.org/toolkit/components/
telemetry/telemetry/data/environment.html).

Is there a control mechanism that allows the user to turn the data

collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's
Preferences.

If the request is for permanent data collection, is there someone who

will monitor the data over time?

Yes, Jim Thomas is responsible.

Using the category system of data types on the Mozilla wiki, what

collection type of data do the requested measurements fall under?

Category 1, Technical.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does there need to be a check-in in the future to determine whether to

renew the data?

No. This collection is permanent.


Result: datareview+

Flags: needinfo?(chutten)

Will the user agent be collected by any or all of those mechanisms, or only at the end by Telemetry as the partial?

Flags: needinfo?(chutten) → needinfo?(jimthomas)

There should be no additional UA capture on the website as a result of this change. UA is already extremely captive before this change.

Yeah, to echo that, there should be no new data collection at any of those steps, the ultimate repository is Telemetry. On the website side, there is already UA information collected that is not in scope for this change.

Flags: needinfo?(jimthomas) → needinfo?(chutten)

Then we're good to go!

Flags: needinfo?(chutten)

QA steps:

  1. download firefox 73 (currently beta) on windows from https://www.mozilla.org/en-US/firefox/channel/desktop/#beta
  2. open firefox 73
  3. go to about:telemetry
  4. search for "attribution" (top right) or click Environment Data -> Settings (left side)

expect: attribution.ua has "chrome" (or "firefox" "edge" "ie" "other" depending on the browser used to download in step 1)

Flags: qe-verify+

(In reply to Ed Lee :Mardak from comment #16)

QA steps:

  1. download firefox 73 (currently beta) on windows from https://www.mozilla.org/en-US/firefox/channel/desktop/#beta
  2. open firefox 73
  3. go to about:telemetry
  4. search for "attribution" (top right) or click Environment Data -> Settings (left side)

expect: attribution.ua has "chrome" (or "firefox" "edge" "ie" "other" depending on the browser used to download in step 1)

Verified with Firefox 73.0b11 (20200128001646) and with Firefox 73.0RC3 (20200207195153)(after updating from 73.0b11 through "beta" channel) on Windows 10x64. "attribution.ua " has the expected attribute when downloaded from different browsers. Tested when downloaded using the above link from "chrome", "firefox", "edge" and "ie".

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1595067
You need to log in before you can comment on or make changes to this bug.