Closed Bug 1595123 Opened 8 months ago Closed 8 months ago

Revert change that may cause same-page ad clicks to not be recorded

Categories

(Firefox :: Search, defect, P1)

defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox-esr68 72+ fixed
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: mikedeboer, Assigned: mikedeboer)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This is a direct regression from bug 1591880, specifically the change to filter on ACTIVITY_SUBTYPE_RESPONSE_COMPLETE type HTTP activities.

Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ef087ab3a6c
Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r=Standard8

Backed out changeset 6ef087ab3a6c (Bug 1595123) for test_urlTelemetry.js failures

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=pending%2Crunning%2Csuccess%2Ctestfailed%2Cbusted%2Cexception&searchStr=linux%2Cx1&fromchange=d8058f03c8bbcc7532f5dc0636a4e680c2210f38&tochange=902b6272602fa378b96d88d316de09a732da3281&selectedJob=275592233

Backout link: https://hg.mozilla.org/integration/autoland/rev/902b6272602fa378b96d88d316de09a732da3281

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=275592233&repo=autoland&lineNumber=2846

[task 2019-11-11T13:59:30.540Z] 13:59:30 INFO - TEST-START | dom/base/test/unit/test_error_codes.js
[task 2019-11-11T13:59:30.661Z] 13:59:30 INFO - TEST-PASS | dom/base/test/unit/test_error_codes.js | took 126ms
[task 2019-11-11T13:59:30.662Z] 13:59:30 INFO - Retrying tests that failed when run in parallel.
[task 2019-11-11T13:59:30.670Z] 13:59:30 INFO - TEST-START | browser/components/search/test/unit/test_urlTelemetry.js
[task 2019-11-11T13:59:30.786Z] 13:59:30 WARNING - TEST-UNEXPECTED-FAIL | browser/components/search/test/unit/test_urlTelemetry.js | xpcshell return code: 0
[task 2019-11-11T13:59:30.787Z] 13:59:30 INFO - TEST-INFO took 110ms
[task 2019-11-11T13:59:30.788Z] 13:59:30 INFO - >>>>>>>
[task 2019-11-11T13:59:30.789Z] 13:59:30 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-11-11T13:59:30.790Z] 13:59:30 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - running event loop
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - browser/components/search/test/unit/test_urlTelemetry.js | Starting test_parsing_search_urls
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - (xpcshell/head.js) | test test_parsing_search_urls pending (2)
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - "Running Google search access point"
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - TEST-PASS | browser/components/search/test/unit/test_urlTelemetry.js | test_parsing_search_urls - [test_parsing_search_urls : 184] {"google.in-content:sap:firefox-b-1-ab":{"bucket_count":3,"histogram_type":4,"sum":1,"range":[1,2],"values":{"0":1,"1":0}}} == true
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - TEST-PASS | browser/components/search/test/unit/test_urlTelemetry.js | test_parsing_search_urls - [test_parsing_search_urls : 185] The histogram must contain the correct key - true == true
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - "Testing Ad URL: https://www.googleadservices.com/aclk=foobar"
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-11-11T13:59:30.791Z] 13:59:30 INFO - PID 18388 | JavaScript strict warning: resource://testing-common/TelemetryTestUtils.jsm, line 77: ReferenceError: reference to undefined property "parent"
[task 2019-11-11T13:59:30.791Z] 13:59:30 WARNING - TEST-UNEXPECTED-FAIL | browser/components/search/test/unit/test_urlTelemetry.js | test_parsing_search_urls - [test_parsing_search_urls : 42] browser.search.ad_clicks must be recorded. - false == true
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - resource://testing-common/TelemetryTestUtils.jsm:assertKeyedScalar:42
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - /builds/worker/workspace/build/tests/xpcshell/tests/browser/components/search/test/unit/test_urlTelemetry.js:testAdUrlClicked:165
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - exiting test
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - Unexpected exception NS_ERROR_ABORT:
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - _abort_failed_test@/builds/worker/workspace/build/tests/xpcshell/head.js:791:20
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - do_report_result@/builds/worker/workspace/build/tests/xpcshell/head.js:892:5
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - Assert<@/builds/worker/workspace/build/tests/xpcshell/head.js:67:21
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - proto.report@resource://testing-common/Assert.jsm:233:10
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - proto.ok@resource://testing-common/Assert.jsm:259:10
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - assertKeyedScalar@resource://testing-common/TelemetryTestUtils.jsm:42:12
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - testAdUrlClicked@/builds/worker/workspace/build/tests/xpcshell/tests/browser/components/search/test/unit/test_urlTelemetry.js:165:24
[task 2019-11-11T13:59:30.792Z] 13:59:30 INFO - async*test_parsing_search_urls@/builds/worker/workspace/build/tests/xpcshell/tests/browser/components/search/test/unit/test_urlTelemetry.js:192:15
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - run_next_test/_run_next_test/<@/builds/worker/workspace/build/tests/xpcshell/head.js:1567:22
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - _run_next_test@/builds/worker/workspace/build/tests/xpcshell/head.js:1567:38
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - run@/builds/worker/workspace/build/tests/xpcshell/head.js:735:9
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:246:6
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:573:5
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - @-e:1:1
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - exiting test
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "parent"" {file: "resource://testing-common/TelemetryTestUtils.jsm" line: 77}]"
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - <<<<<<<
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - INFO | Result summary:
[task 2019-11-11T13:59:30.793Z] 13:59:30 INFO - INFO | Passed: 680
[task 2019-11-11T13:59:30.793Z] 13:59:30 WARNING - INFO | Failed: 1
[task 2019-11-11T13:59:30.794Z] 13:59:30 WARNING - One or more unittests failed.
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - INFO | Todo: 0
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - INFO | Retried: 1
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - SUITE-END | took 283s
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - Node moz-http2 server shutting down ...
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - Process stderr
[task 2019-11-11T13:59:30.794Z] 13:59:30 INFO - (node:1084) ExperimentalWarning: The http2 module is an experimental API.
[task 2019-11-11T13:59:30.865Z] 13:59:30 ERROR - Return code: 1
[task 2019-11-11T13:59:30.866Z] 13:59:30 INFO - TinderboxPrint: xpcshell-xpcshell<br/>680/<em class="testfail">1</em>/0
[task 2019-11-11T13:59:30.866Z] 13:59:30 WARNING - # TBPL FAILURE #
[task 2019-11-11T13:59:30.866Z] 13:59:30 WARNING - setting return code to 2
[task 2019-11-11T13:59:30.866Z] 13:59:30 WARNING - The xpcshell suite: xpcshell ran with return status: FAILURE
[task 2019-11-11T13:59:30.866Z] 13:59:30 INFO - Running post-action listener: _package_coverage_data
[task 2019-11-11T13:59:30.866Z] 13:59:30 INFO - Running post-action listener: _resource_record_post_action
[task 2019-11-11T13:59:30.866Z] 13:59:30 INFO - Running post-action listener: process_java_coverage_data
[task 2019-11-11T13:59:30.867Z] 13:59:30 INFO - [mozharness: 2019-11-11 13:59:30.865992Z] Finished run-tests step (success)
[task 2019-11-11T13:59:30.867Z] 13:59:30 INFO - Running post-run listener: _resource_record_post_run
....

Flags: needinfo?(mdeboer)

le: this also happens on Windows and OS X.

Attachment #9107539 - Attachment description: Bug 1595123 - Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r?Standard8! → Bug 1595123 - Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r=Standard8
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c1ac6c58870
Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Assignee: nobody → mdeboer
Flags: needinfo?(mdeboer)

Setting ESR68 status to affected for now in the event that we end up uplifting the regressing bug there eventually.

Comment on attachment 9107539 [details]
Bug 1595123 - Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r=Standard8

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This is a very simple follow-up fix for bug 1591880, which caused the regression. It is simply required to be included IF the patches in bug 1591880 are approved for uplift to ESR 68.
  • User impact if declined: Some ad clicks may not get recorded properly when only the patches from bug 1591880 are uplifted.
  • Fix Landed on Version: 72
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No regressions have been found by our data scientists since this patch has landed.
  • String or UUID changes made by this patch: n/a
Attachment #9107539 - Flags: approval-mozilla-esr68?

Comment on attachment 9107539 [details]
Bug 1595123 - Revert change to observe HTTP activity of type ACTIVITY_SUBTYPE_RESPONSE_COMPLETE, which causes same-page ad clicks to not be counted. r=Standard8

Regression fix for bug 1591880. Approved for 68.4esr.

Attachment #9107539 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
You need to log in before you can comment on or make changes to this bug.