Closed Bug 1595131 Opened 1 year ago Closed 1 year ago

browsertime setup: HTTPError: 404 Client Error: Not Found for url: https://imagemagick.org/download/binaries/ImageMagick-x86_64-apple-darwin18.7.0.tar.gz

Categories

(Testing :: Performance, defect)

Version 3
Unspecified
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1594219

People

(Reporter: mayhemer, Unassigned)

References

(Blocks 2 open bugs)

Details

./mach browsertime --setup
 0:00.47 Downloading artifact to local cache: /Users/honzabambas/.mozbuild/cache/browsertime/9ac930ee5a39c772-ImageMagick-x86_64-apple-darwin18.7.0.tar.gz
 0:01.17 Downloading... 0.0 %
 0:01.17 Downloading... 100.0 %
Error running mach:

    ['browsertime', '--setup']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

HTTPError: 404 Client Error: Not Found for url: https://imagemagick.org/download/binaries/ImageMagick-x86_64-apple-darwin18.7.0.tar.gz

  File "/Users/honzabambas/Mozilla/src/mozilla-central/tools/browsertime/mach_commands.py", line 427, in browsertime
    return self.setup(should_clobber=clobber)
  File "/Users/honzabambas/Mozilla/src/mozilla-central/tools/browsertime/mach_commands.py", line 200, in setup
    archive = artifact_cache.fetch(fetch['url'])
  File "/Users/honzabambas/Mozilla/src/mozilla-central/python/mozbuild/mozbuild/artifact_cache.py", line 208, in fetch
    dl.wait()
  File "/Users/honzabambas/Mozilla/src/mozilla-central/third_party/python/dlmanager/dlmanager/manager.py", line 101, in wait
    self.raise_if_error()
  File "/Users/honzabambas/Mozilla/src/mozilla-central/third_party/python/dlmanager/dlmanager/manager.py", line 116, in raise_if_error
    six.reraise(*self.__error)
  File "/Users/honzabambas/Mozilla/src/mozilla-central/third_party/python/dlmanager/dlmanager/manager.py", line 175, in _download
    response.raise_for_status()
  File "/Users/honzabambas/Mozilla/src/mozilla-central/third_party/python/requests/requests/models.py", line 840, in raise_for_status
    raise HTTPError(http_error_msg, response=self)

Hi Honza - is your tree up-to-date? If so, maybe blowing away your /.mozbuild/cache/browsertime/ directory, and re-running ./mach browsertime --setup, would help? This should have been fixed in bug 1594219.

Flags: needinfo?(honzab.moz)

(In reply to Stephen Donner [:stephend] from comment #1)

Hi Honza - is your tree up-to-date?

yes, to the date of the report.

If so, maybe blowing away your /.mozbuild/cache/browsertime/ directory, and re-running ./mach browsertime --setup, would help?

This was an ever first run of ./mach browsertime --setup on the machine.

This should have been fixed in bug 1594219.

will retry with this patch in the tree and report back, thanks!

Flags: needinfo?(honzab.moz)

(In reply to Honza Bambas (:mayhemer) from comment #2)

(In reply to Stephen Donner [:stephend] from comment #1)

Hi Honza - is your tree up-to-date?

yes, to the date of the report.

rebased

If so, maybe blowing away your /.mozbuild/cache/browsertime/ directory, and re-running ./mach browsertime --setup, would help?

This was an ever first run of ./mach browsertime --setup on the machine.

done after the rebase

This should have been fixed in bug 1594219.

will retry with this patch in the tree and report back, thanks!

and getting:

./mach browsertime --setup
 0:01.07 Downloading artifact to local cache: /Users/<user>/.mozbuild/cache/browsertime/8745c3584f51f06e-ImageMagick-x86_64-apple-darwin18.7.0.tar.gz
 0:01.57 Downloading... 0.0 %
 0:02.09 Downloading... 5.0 %
 0:02.46 Downloading... 10.0 %
 0:02.88 Downloading... 15.1 %
 0:03.29 Downloading... 20.0 %
 0:03.71 Downloading... 25.1 %
 0:04.13 Downloading... 30.0 %
 0:04.55 Downloading... 35.1 %
 0:04.96 Downloading... 40.0 %
 0:05.38 Downloading... 45.1 %
 0:05.80 Downloading... 50.0 %
 0:06.21 Downloading... 55.0 %
 0:06.63 Downloading... 60.1 %
 0:07.04 Downloading... 65.0 %
 0:07.47 Downloading... 70.1 %
 0:07.88 Downloading... 75.0 %
 0:08.31 Downloading... 80.1 %
 0:08.72 Downloading... 85.0 %
 0:09.14 Downloading... 90.1 %
 0:09.55 Downloading... 95.0 %
 0:09.97 Downloading... 100.0 %
 0:09.97 Unpacking temporary location /Users/<user>/.mozbuild/cache/browsertime/8745c3584f51f06e-ImageMagick-x86_64-apple-darwin18.7.0.tar.gz
Error running mach:

    ['browsertime', '--setup']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: Cannot find an extracted directory: /Users/<user>/.mozbuild/browsertime/ImageMagick-7.0.8

  File "/Users/<user>/Mozilla/src/mozilla-central/tools/browsertime/mach_commands.py", line 427, in browsertime
    return self.setup(should_clobber=clobber)
  File "/Users/<user>/Mozilla/src/mozilla-central/tools/browsertime/mach_commands.py", line 218, in setup
    raise Exception("Cannot find an extracted directory: %s" % path)

Which is similar to the other bug I reported recently for windows, bug 1594795

the directory content looks like:

ImageMagick-7.0.9

the version is wrong.

btw, this is on OSX

OS: Unspecified → macOS
Blocks: rel=preload

So, I think the specific problem reported here originally is fixed (provably a duplicate of bug 1594219.) The problem from comment 3 is duplicate of bug 1594795.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1594219
You need to log in before you can comment on or make changes to this bug.