Closed Bug 1595656 Opened 2 years ago Closed 2 years ago

browsingData API will disconnect sync if passwords are cleared

Categories

(WebExtensions :: General, defect)

70 Branch
defect
Not set
normal

Tracking

(firefox72 verified, firefox73 verified)

VERIFIED FIXED
mozilla72
Tracking Status
firefox72 --- verified
firefox73 --- verified

People

(Reporter: covert0001, Assigned: MattN)

Details

Attachments

(3 files)

Attached file Sync-log.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

It happens on a regular basis

Actual results:

I get the notification to reconnect to sync on the open menu. this happens on both my PCs

Expected results:

I expected that I don't need to reconnect to sync several times in a day. I have attached the log,

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Sync

Sorry you are having this issue. We have seen similar issues when a file in your profile has been damaged, but it's very unusual for it to happen on multiple PCs unless you actually changed/reset your password in the process of reconnecting. If you don't mind answering some questions it might help us work out what it going wrong:

  • Have you changed or reset your password recently in an attempt to resolve this?

  • Do you expect to have any passwords saved locally? If so, do you see them in about:preferences#privacy? (Sometimes when we see this issue, another symptom is that all passwords are lost, so I'm trying to see if this might be that problem)

  • Do you have a master-password set on either device?

  • What anti-virus do you use? Do you mind disabling it and checking that the problem still exists?

  • Can you please restart the browser, open the "Browser Console" by pressing Ctrl+Shift+J, waiting for sync to tell you about the connection problem, then paste any messages in that console to this bug?

Hopefully we can help get to the problem of this!

Flags: needinfo?(covert0001)

Thanks for you prompt reply, the answers to you questions:
I have not changed my password, I use LastPass password manager
I do not save any passwords locally.
I do not have a master password, other than my W10 pin number
I use ESET Nod 32 I have disabled it but the problem persists
Below is message from the browser.

[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.open]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 772" data: no] 3 L10nRegistry.jsm:772:12
Unknown category for SetEventRecordingEnabled: fxmonitor
No such native application com.lastpass.nplastpass NativeMessaging.jsm:112
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xhtml
Log warning: The log 'Services.Common.RESTRequest' is configured to use the preference 'services.common.log.logger.rest.request' - you must adjust the level by setting this preference, not by using the level setter Log.jsm:24
Content Security Policy: Ignoring ‘x-frame-options’ because of ‘frame-ancestors’ directive.
Error: WebExtension context not found! ExtensionParent.jsm:1275:13
Content Security Policy: Ignoring ‘x-frame-options’ because of ‘frame-ancestors’ directive.
Error: WebExtension context not found! ExtensionParent.jsm:1275:13
[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.open]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 772" data: no] L10nRegistry.jsm:772:12
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 759" data: no] L10nRegistry.jsm:759:19
[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.open]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 772" data: no] L10nRegistry.jsm:772:12
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 759" data: no] L10nRegistry.jsm:759:19

Flags: needinfo?(covert0001)

(In reply to Paul from comment #3)

I use ESET Nod 32 I have disabled it but the problem persists

That's very strange. To be clear, if you disable that software, I wouldn't expect the problem to immediately be solved - instead, I'd hope it doesn't come back. For example, after disabling that software, you may still find you need to reconnect - but hopefully after reconnecting, you would then stay connected. Can you please try again with this in mind? And just to rule everything out, maybe try disabling LastPass too? And maybe all other extensions?

Unfortunately, those log messages don't include anything useful. I see you have found about:sync-log - the previous log you attached also didn't have anything useful, but what might help is:

  • delete all old logs - they are under 'weave/logs' in your profile directory - or just note what files are already there.
  • exit the browser and start it up.
  • wait for the problem to occur.
  • do the sign-in to solve the problem.
  • attach all new logs created from that process to this bug. Note that there may be a number of logs - please be sure to attach them all.

Sorry this is so painful, but this is a very unusual situation - thanks for your patience.

Flags: needinfo?(covert0001)

I am currently checking all my add-ons, first I disabled all add-ons and the problem seemed to go away, then enabled them one at a time. The problem is Forget Me Not even though I have added Firefox and Mozilla as "Never clear".

POSThttps://accounts.firefox.com/metrics
[HTTP/1.1 200 OK 203ms]

[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.open]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 772" data: no] 3 L10nRegistry.jsm:772:12
loadSync resource://gre/modules/L10nRegistry.jsm:772
fetchFile resource://gre/modules/L10nRegistry.jsm:674
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:579
map self-hosted:291
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:574
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:410
next self-hosted:1255
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:419
next self-hosted:1255
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:419
next self-hosted:1255
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:172
InterpretGeneratorResume self-hosted:1300
next self-hosted:1255
touchNext resource://gre/modules/Localization.jsm:167
onChange resource://gre/modules/Localization.jsm:500
Localization resource://gre/modules/Localization.jsm:227
getLocalization resource://gre/modules/Localization.jsm:638
Error: listener not re-registered 14 ExtensionCommon.jsm:2336:24
No such native application com.lastpass.nplastpass NativeMessaging.jsm:112
Sync encountered an error - see about:sync-log for the log file. policies.js:1005
POSThttps://accounts.firefox.com/metrics
[HTTP/1.1 200 OK 203ms]

Error in parsing value for 'grid-template-rows'. Declaration dropped. App.css:73:23
Error in parsing value for 'grid-template-rows'. Declaration dropped. App.css:141:23
GEThttps://lp-push-server-893.lastpass.com/ws/9951d24429843cd6ab52df9fab61eaa44e3803198149fc4746c02dcfef6f6613
[HTTP/1.1 101 Switching Protocols 1139ms]

XHRGEThttps://api.accounts.firefox.com/v1/recovery_email/status
[HTTP/1.1 200 OK 201ms]

XHRPOSThttps://tiles.services.mozilla.com/v3/links/ping-centre
[HTTP/1.1 200 OK 201ms]

GEThttps://snippets.cdn.mozilla.net/media/icons/c46c6cdf-ef2d-460a-9009-8c1ccbbe84c6.png
[HTTP/1.1 200 OK 60ms]

GEThttps://snippets.cdn.mozilla.net/media/icons/5878847e-a1fb-4204-aad9-09f6cf7f99ee.png
[HTTP/1.1 200 OK 57ms]

GEThttps://bugzilla.mozilla.org/show_bug.cgi?id=1595656
[HTTP/1.1 200 OK 2493ms]

POSThttp://ocsp.digicert.com/
[HTTP/1.1 200 OK 94ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/yui.css
[HTTP/1.1 200 OK 203ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/global.css
[HTTP/1.1 200 OK 206ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BugModal/web/bug_modal.css
[HTTP/1.1 200 OK 977ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/plugins/contextMenu/contextMenu.css
[HTTP/1.1 200 OK 978ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BMO/web/styles/bug_modal.css
[HTTP/1.1 200 OK 400ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/EditComments/web/styles/inline-editor.css
[HTTP/1.1 200 OK 1005ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/ui/jquery-ui-min.css
[HTTP/1.1 200 OK 1012ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/ui/jquery-ui-structure-min.css
[HTTP/1.1 200 OK 406ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/ui/jquery-ui-theme-min.css
[HTTP/1.1 200 OK 595ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/lib/prism.css
[HTTP/1.1 200 OK 591ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/Needinfo/web/styles/needinfo.css
[HTTP/1.1 200 OK 758ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/Review/web/styles/badge.css
[HTTP/1.1 200 OK 773ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/jquery-min.js
[HTTP/1.1 200 OK 958ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/ui/jquery-ui-min.js
[HTTP/1.1 200 OK 996ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/yui.js
[HTTP/1.1 200 OK 1389ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/plugins/contextMenu/contextMenu-min.js
[HTTP/1.1 200 OK 793ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/jquery/plugins/devbridgeAutocomplete/devbridgeAutocomplete-min.js
[HTTP/1.1 200 OK 942ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/global.js
[HTTP/1.1 200 OK 966ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/util.js
[HTTP/1.1 200 OK 992ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/dropdown.js
[HTTP/1.1 200 OK 1130ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BugModal/web/autosize.min.js
[HTTP/1.1 200 OK 1146ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/ProdCompSearch/web/js/prod_comp_search.js
[HTTP/1.1 200 OK 1160ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BugModal/web/bug_modal.js
[HTTP/1.1 200 OK 1193ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BugModal/web/comments.js
[HTTP/1.1 200 OK 1194ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/ComponentWatching/web/js/overlay.js
[HTTP/1.1 200 OK 1326ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/bugzilla-readable-status-min.js
[HTTP/1.1 200 OK 1335ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/field.js
[HTTP/1.1 200 OK 1355ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/comments.js
[HTTP/1.1 200 OK 1387ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/TrackingFlags/web/js/flags.js
[HTTP/1.1 200 OK 1388ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BMO/web/js/firefox-crash-table.js
[HTTP/1.1 200 OK 1516ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/lib/prism.js
[HTTP/1.1 200 OK 1527ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BMO/web/js/edituser_menu.js
[HTTP/1.1 200 OK 1550ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/GoogleAnalytics/web/js/analytics.js
[HTTP/1.1 200 OK 1577ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/js/lib/md5.min.js
[HTTP/1.1 200 OK 1579ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/Review/web/js/badge.js
[HTTP/1.1 200 OK 1581ms]

GEThttps://secure.gravatar.com/avatar/59665fa91c59fd06f5e519e00e965f43?d=mm&size=64
[HTTP/2.0 200 OK 266ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/extensions/BMO/web/images/moz-fav-one-color-white-rgb.svg
[HTTP/1.1 200 OK 1587ms]

GEThttps://bugzilla.mozilla.org/extensions/BugModal/web/throbber.gif
[HTTP/1.1 200 OK 1604ms]

GEThttps://bugzilla.mozilla.org/extensions/ProdCompSearch/web/images/throbber.gif
[HTTP/1.1 200 OK 1600ms]

GEThttps://bugzilla.mozilla.org/extensions/BugModal/web/error.png
[HTTP/1.1 200 OK 1598ms]

GEThttps://secure.gravatar.com/avatar/59665fa91c59fd06f5e519e00e965f43?d=mm&size=40
[HTTP/2.0 200 OK 157ms]

GEThttps://secure.gravatar.com/avatar/90befef2df2066c3deff0d97cdaa6916?d=mm&size=40
[HTTP/2.0 200 OK 156ms]

GEThttps://secure.gravatar.com/avatar/9eb8612b118640351041fb0877c5fc8f?d=mm&size=64
[HTTP/2.0 200 OK 151ms]

GEThttps://secure.gravatar.com/avatar/90befef2df2066c3deff0d97cdaa6916?d=mm&size=64
[HTTP/2.0 200 OK 175ms]

GEThttps://secure.gravatar.com/avatar/e2a8a07d989642286b17784f011de457?d=mm&size=64
[HTTP/2.0 200 OK 174ms]

GEThttps://bugzilla.mozilla.org/extensions/BMO/web/images/notice.png
[HTTP/1.1 200 OK 1597ms]

XHRGEThttp://detectportal.firefox.com/success.txt
[HTTP/1.1 200 OK 21ms]

GEThttp://detectportal.firefox.com/success.txt?ipv4
[HTTP/1.1 200 OK 20ms]

GEThttp://detectportal.firefox.com/success.txt?ipv6
GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/FiraGO-Book.woff2?v=1.001
[HTTP/1.1 200 OK 810ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/FiraGO-SemiBold.woff2?v=1.001
[HTTP/1.1 200 OK 1147ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/FiraGO-Medium.woff2?v=1.001
[HTTP/1.1 200 OK 1380ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/MaterialIcons-Regular.woff2
[HTTP/1.1 200 OK 607ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/FiraGO-BookItalic.woff2?v=1.001
[HTTP/1.1 200 OK 1542ms]

GEThttps://bugzilla.mozilla.org/static/v20191106.1/skins/standard/fonts/FiraGO-SemiBoldItalic.woff2?v=1.001
[HTTP/1.1 200 OK 813ms]

XHRGEThttps://bugzilla.mozilla.org/rest/bug_user_last_visit/1595656?Bugzilla_api_token=me4B3wiaKgHZ4psnj9XpGw
[HTTP/1.1 200 OK 858ms]

XHRGEThttps://bugzilla.mozilla.org/rest/component-watching?Bugzilla_api_token=me4B3wiaKgHZ4psnj9XpGw
[HTTP/1.1 200 OK 1044ms]

XHRPOSThttps://bugzilla.mozilla.org/rest/bug_user_last_visit/1595656?Bugzilla_api_token=me4B3wiaKgHZ4psnj9XpGw
[HTTP/1.1 200 OK 379ms]

GEThttps://www.google-analytics.com/analytics.js
[HTTP/2.0 200 OK 42ms]

GEThttps://bugzilla.mozilla.org/extensions/BMO/web/images/favicon.ico
[HTTP/1.1 200 OK 212ms]

POSThttps://www.google-analytics.com/r/collect
[HTTP/2.0 200 OK 140ms]

XHRGEThttps://bugzilla.mozilla.org/rest/bug/attachment/9108016?include_fields=data&Bugzilla_api_token=me4B3wiaKgHZ4psnj9XpGw
[HTTP/1.1 200 OK 313ms]

GEThttps://lp-push-server-893.lastpass.com/ws/9951d24429843cd6ab52df9fab61eaa44e3803198149fc4746c02dcfef6f6613

Flags: needinfo?(covert0001)

From the description for this add-on it sounds like it may clear saved passwords on browser startup, which would explain what's going on here (it would clear the saved credentials for Firefox Sync, which we store in the password manager for security reasons). Does the addon have an option to disable clearing of saved passwords?

I can repro this - the addon uses https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/browsingData which happily deletes all saved passwords, including sync's credentials. I think this is clearly a bug in the API implementation rather than the addon.

Status: UNCONFIRMED → NEW
Component: Sync → General
Ever confirmed: true
Product: Firefox → WebExtensions
Summary: Firefox sync disconnects → browsingData API will disconnect sync is passwords are cleared

...or maybe it's a loginmgr bug? The webext api implementation ends up calling removeAllLogins()...

Summary: browsingData API will disconnect sync is passwords are cleared → browsingData API will disconnect sync if passwords are cleared

Thanks Mark - but the last 2 comments are beyond my knowledge, is there something I can do?

(In reply to Paul from comment #9)

Thanks Mark - but the last 2 comments are beyond my knowledge, is there something I can do?

Did you see comment 6? That would solve the problem for you.

(In reply to Mark Hammond [:markh] from comment #7)

I can repro this - the addon uses https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/browsingData which happily deletes all saved passwords, including sync's credentials. I think this is clearly a bug in the API implementation rather than the addon.

I think this should be fixed in the webext API and leave removeAllLogins not Firefox-specific (it's used by Thunderbird too). This can be easily done by always looping over LoginHelper.getAllUserFacingLogins() instead of sometimes getAllLogins() or sometimes calling removeAllLogins(). getAllUserFacingLogins has the added benefit of being quite a bit faster since it uses bulk/batch decryption.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Summary: browsingData API will disconnect sync if passwords are cleared → browsingData.removePasswords() API will disconnect sync if passwords are cleared

I didn't realize there were two APIs to clear passwords.

Summary: browsingData.removePasswords() API will disconnect sync if passwords are cleared → browsingData API will disconnect sync if passwords are cleared

We shouldn't hide data saved by legacy extensions, the user should remain in control of them since they may container credentials they want to delete.

FxA/Sync stores a credential in login storage but this is no longer user-facing so users shouldn't expect it to be cleared. Users can still diconnect Sync properly from about:preferences.

Depends on D53833

Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/ef8d5090979a
isUserFacingLogin should only exclude the FxA one, not legacy extension ones. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/061c92c4b95c
Only clear user-facing passwords with the browsingData API. r=rpl
Flags: needinfo?(MattN+bmo)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/bb120dcc1726
isUserFacingLogin should only exclude the FxA one, not legacy extension ones. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/942c83d4c62d
Only clear user-facing passwords with the browsingData API. r=rpl
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hello,

Could you please provide some repro steps for this issue in order to be able to manually verify this fix?
What I have tried so far was (On Windows 10 64-bit on FF 70 and 71):

  1. Launch clean profile and login with existing firefox account.
  2. verify in about:preferences> Saved login that the account username and password have been saved.
  3. Install https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager/.
  4. Create a Last pass account using the firefox account data and log in.

After this step is diverged into multiple scenarios:
A. Save the firefox sign in link, username and password in LastPass, sign out the firefox accoutn and restart browser. Sign in again after restart and check about:sync=log page.
B. Save firefox sign in link, username and password in LastPass and restart the browser. Sync the account and verify log.
C. Do not save any password in LastPass , sign out of the firefox account, restart the browser and sign in again.
C. Sign in with firefox account on another FF profile and choose to sync now. Verify sync logs.

The expectation was that somehow through Last pass the sync credentials are cleared on browser startup so there must be something I am missing in my reproduction attempts.

Flags: needinfo?(MattN+bmo)

(In reply to Miruna Curtean from comment #18)

Hello,

Could you please provide some repro steps for this issue in order to be able to manually verify this fix?
...

Hi Miruna,
looking to the other bugzilla comments in this issue, it seems that the extension needed to reproduce the issue and verify the fix is actually Forget Me Not (mentioned in comment 5, 6 and 7).

The STR should be something like:

  1. Launch clean profile and login with existing firefox account.
  2. verify in about:preferences> Saved login that the account username and password have been saved.
  3. Install https://addons.mozilla.org/en-US/firefox/addon/forget_me_not and use it to clear login and passwords (I'm not sure where that feature is going to be available in the extension itself, the reporter may provide some details about that if you are unable to trigger the bug using this extension)
  4. verify in about:preferences> Saved login that the account username and password are still saved.
Flags: needinfo?(MattN+bmo)

(In reply to Luca Greco [:rpl] [:luca] [:lgreco] from comment #19)

  1. verify in about:preferences> Saved login that the account username and password have been saved.

The sync credential in question isn't visible in about:logins and that's a reason we shouldn't clear it via the API.

Here are STR:

  1. Launch clean profile and set up Sync with an existing firefox account and verify it syncs changes to another synced device/profile.
  2. Save a regular website login in Firefox.
  3. Install https://addons.mozilla.org/firefox/addon/forget_me_not and use it to clear login and passwords (I'm not sure where that feature is going to be available in the extension itself, the reporter may provide some details about that if you are unable to trigger the bug using this extension). I think you need to check the passwords option at https://addons.cdn.mozilla.net/user-media/previews/full/224/224279.png?modified=1567357911 and then maybe restart or force the deletion somehow?
  4. Restart Firefox

Expected result:

  • The website login from step 2 was removed from about:logins.
  • New changes to synced data types still sync to the other device/profile.

Thank you for the STR, both Luca and Matthew.
In order to also test the sync today I've followed the STR from comment 20.
Testing was performed on Pro Windows 10 64-bit and macOS Catalina 10.15 using Firefox nightly 73.0a1 (20191209095039) and Firefox Beta 72.0b4 (20191206183317).
When on one of the synced devices the passwords and logins are erased using Forget Me Not add-on, they are also removed from the other device/ browser about:login page after Sync Now or Restart (which forces the account to sync).
Another thing that was verified was any data which was bookmarked or saved on on one of the synced profiles was also added or removed (depending on the action performed) from the other profile after sync.
Based on obtaining those expected results I am marking this ticket as Verified fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.