Text does not wrap in P tag if the window is taller than somewhat about 600 pixel

RESOLVED WORKSFORME

Status

()

Core
Layout
--
minor
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Georg Maaß, Assigned: Marc Attinasi)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
Text does not wrap in P tag if the window is taller than somewhat about 600
pixel. If you increas the window width then it wraps correctly.

Problem occures on windows and linux with 1.0 and 1.0rc2

Comment 1

16 years ago
   Reporter: could you please  read  the  Bug  Writing  Guidelines  at
http://www.mozilla.org/quality/bug-writing-guidelines.html to see  the
kinds of information we need in a bug report. Please report back  with
more information (like BuildID and steps to reproduce)  after  reading
those guidelines and consider using  the  Bugzilla  Helper  to  report
future bugs.

   The Helper can be found at
   http://www.mozilla.org/quality/help/bug-form.html
   Thanks for your help in testing Mozilla.
WFM in trunk build 2002072408, WinXP.

Comment 3

16 years ago
WORKSFORME, 2002-07-25-08 (trunk) on Linux.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
I've written the Releases to my report.
The build of my linux Mozilla is 2002051009 (1.0rc2)
The build number of the 1.0 release on Windows is available only on my working
place on monday. Both are official releases or release candidates like my linux
exemplar.
(Reporter)

Comment 5

16 years ago
build number of Mozilla 1.0 running on windows 2000 is 2002053012
(Reporter)

Comment 6

16 years ago
I now inserted a JavaScript, which resizes the window to a size (300x300), which
demonstrates the propblem. I hope you will see it now too.
(Reporter)

Comment 7

16 years ago
Created attachment 93150 [details]
Screenshot

I pasted the missing part of the text to the right side of the screenshot and
marked it with a big red array.

Comment 8

16 years ago
REOPEN. (I cannot reproduce it, but the screenshot clearly shows a problem
of some sort...)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

16 years ago
--> Browser-General
Assignee: attinasi → Matti
Severity: normal → minor
Component: Layout → Browser-General
OS: Linux → All
QA Contact: petersen → asa
(Reporter)

Comment 10

16 years ago
Created attachment 93267 [details]
Screenshot with more content

There are no scrollbars visible but it is vertically scrollable. It is not
horizontally scrollable. This is very curious.

Screenshot made using Mozilla 1.0 on W2K (2002053012)
(Reporter)

Comment 11

16 years ago
Created attachment 93387 [details]
static test case

This file generates a popup of the desired size as in the original application
and then loads it self into that popup. The problem occures in this popup.
wfm with wi2nk build 20020730..

-> wfm

please reopen if you see this with Mozilla1.1b or later
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
Created attachment 93576 [details]
screen cap

using moz1.1b on winme.

i do see this problem.	i am attaching a screen cap based on the static test
case attached above (attachment 93387 [details]).  however, i have reduced the size of
the popup window to exaggerate this problem.  the text in the popup can be
compared to the text in the main window in back.

also, by increasing the horizontal width slowly, you can see the scrollbar
eventually come into view - as if the smaller sized popup is too narrow to
display all the window and chrome contents out to the right edge.  after the
popup window is wide enough for the full scrollbar to appear, proper text
wrapping occurs.

one can surmise the same problem with the vertical direction, although
extending the popup window vertically does not eventually display the bottom
scrollbar.

i believe another bug exists for this problem, but i can't find it right now.
(Reporter)

Comment 14

16 years ago
Created attachment 93712 [details]
screenshot made with newest nighly

This scream shot was made with build 202080204 on Win2K
(Reporter)

Comment 15

16 years ago
> please reopen if you see this with Mozilla1.1b or later

reopened because the bug it is still present also in build 2002080204 as you can
see in the screenshot above
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
-> Layout
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: asa → petersen

Comment 17

16 years ago
this may be a dupe of bug 154230.

Comment 18

16 years ago
Marking WFM in the 2002-10-02-08 OS X build. Probably fixed by bug 154230.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

16 years ago
I just run the static testcase with this browser, but the bug still is present.
It is not fixed

Mozilla 1.2b

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020926
(Reporter)

Comment 20

16 years ago
Just tested the static testcase with Mozilla 1.2b Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.2b) Gecko/20021006, but the bug still is present.
It is not fixed. Trying to reopen the bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 21

16 years ago
Works for me, using nightly 2003011105 for linux. Loading the static test case,
the popup window has a scrollbar, and the text within it is flowed and doesn't
seem to be missing anything.

Note that for the popup to appear, you have to allow javascript to open
unrequested windows.

Georg, if you can still reproduce this, could you provide the default font
settings you're using? Also, please go into Edit->Preferences->Advanced->Scripts
& Plugins, and describe how you've set things there.

Comment 22

16 years ago
please also verify that you can reproduce this with a fresh profile.
(Reporter)

Comment 23

16 years ago
I'm just downloading the newest nightly but it also works well with this one.

Mozilla 1.3a
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123

The problem seams to be fixed.

Tomorrow I'll at my working place I'll download also the newst Win Mozilla to
see, what it does there.
(Reporter)

Comment 24

16 years ago
Mozilla 1.3b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030111

This also works well.

No new profile was necessary to work well. It works well with the existing profile.

Comment 25

16 years ago
thanks Georg.  marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 26

16 years ago
Mozilla 1.3b
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030112

works well too. So this bug seams to be fixed.
You need to log in before you can comment on or make changes to this bug.