Open Bug 1595743 Opened 1 year ago Updated 1 month ago

[Dark Theme] Hover feedback is missing in the autocomplete dropdown

Categories

(Firefox :: Theme, defect, P3)

Desktop
All
defect

Tracking

()

Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- wontfix

People

(Reporter: tbabos, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [passwords:fill-ui])

Attachments

(1 file, 1 obsolete file)

Attached video Video of the issue

Affected versions
Nightly 72.0a1 (2019-11-11)
Beta 71.0b8
Release 70.0.1

Affected platforms
Windows 10
MacOS
Ubuntu 18.04

Steps to reproduce

  • Launch Firefox
  • Set up available Dark theme or download and use any dark theme
  • Go to facebook.com
  • Fill in one or two set of credentials and save them
  • Reload the site
  • Toggle the autocomplete dropdown for the username or password field
  • Hover over the listed options

Expected result
While hovering over any of the listed options a hover effect should be displayed,

Actual Result
The hover highlight is not displayed when dark themes are applied

Note
This is also reproducible with High Contrast White theme

:tbabos, could you track down a regression range for this? I'm not sure if this is due to theme changes, or login autocomplete changes.

Flags: needinfo?(tbabos)

Maybe :ntim is interested in investigating?

Flags: needinfo?(ntim.bugs)

Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fa5724780fe76d6ccbbd08d978342a1db6a43d49&tochange=5b15326286d466b5cf4889160cc09b59bdde08fd

Regressed by:
8885e98d44d4a34619e5840b160f48d0b89a1337 Harry Twyford — Bug 1453722 - Improvements to Dark Theme search bar. r=dao

The changing of rule for :root[lwt-popup-brighttext] in browser.css seems to cause the problem.

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1453722
Component: Password Manager → Theme
Flags: needinfo?(tbabos)
Product: Toolkit → Firefox
Whiteboard: [passwords:fill-ui]

So what's happening here is that the autocomplete popup is using var(--arrowpanel-dimmed) for the hover state (https://searchfox.org/mozilla-central/rev/cac340f10816707e91c46db6d285f80259420f07/browser/themes/shared/autocomplete.inc.css#32-34), but isn't using var(--arrowpanel-background) for the popup background. It should either use exclusively the var(--arrowpanel-*) variables, or exclusively use system colors, the latter should be easier to do I think.

Flags: needinfo?(ntim.bugs)
Depends on: 1553682
Priority: -- → P3
Summary: [Dark Theme] Hover highlighter is missing in the autocomplete dropdown → [Dark Theme] Hover feedback is missing in the autocomplete dropdown

Hey, would it be possible to attempt to take this one on as a first commit?

Tim, can you offer guidance to Brandon?

Sorry, I don't have time to mentor this, maybe Dão has ?

Flags: needinfo?(ntim.bugs) → needinfo?(dao+bmo)
Flags: needinfo?(dao+bmo)
Duplicate of this bug: 1571065
Blocks: dark-mode

By the way, this came up on SUMO today for the built-in Dark theme: https://support.mozilla.org/questions/1295686

The user wasn't able to resolve the problem with add-on themes (that might also be a known issue).

Duplicate of this bug: 1653571
Assignee: nobody → severin.mozilla
Status: NEW → ASSIGNED
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/762d1972d011
fix dark theme popup hover color;r=MattN
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Regressions: 1661244

:aryx, would you mind backing this out (of both central and beta)? It caused a regression, and I'm working on something critical right now and won't have time to fix it in the near future.

Flags: needinfo?(aryx.bugmail)

Needinfoing myself to fix + reland.

Flags: needinfo?(severin.mozilla)
Whiteboard: [passwords:fill-ui] → [passwords:fill-ui] , [checkin-needed-beta]
Status: RESOLVED → REOPENED
Flags: needinfo?(aryx.bugmail)
Resolution: FIXED → ---
Target Milestone: 81 Branch → ---
Whiteboard: [passwords:fill-ui] , [checkin-needed-beta] → [passwords:fill-ui]

I'm not going to have a chance to fix this one.

Flags: needinfo?(severinrudie)
Assignee: severinrudie → nobody
Duplicate of this bug: 1667322
Assignee: nobody → severinrudie
Assignee: severinrudie → nobody
Status: REOPENED → NEW
Assignee: nobody → severinrudie
Status: NEW → ASSIGNED
Attachment #9169934 - Attachment is obsolete: true
Assignee: severinrudie → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.