Closed Bug 1595842 Opened 4 months ago Closed 3 months ago

Import settings wizard dynamic triplets onboarding card for chrome switchers

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox72 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files, 1 obsolete file)

Scope of this bug is to invoke File > Import from Another Browser... from Chrome switcher onboarding card and add a new chrome switchers onboarding card inside dynamic triplets

Blocks: 1591165

Import wizard is invoked from

ActivityStream used to previously support import settings from new tab (https://github.com/mozilla/activity-stream/issues/2787),
this functionality was reverted with https://github.com/mozilla/activity-stream/pull/4918

MigrationUtils.showMigrationWizard was invoked by ManualMigration.jsm from a content dispatched action on the new tab page.

Assignee: nobody → pdahiya
Iteration: --- → 72.3 - Nov 18 - Dec 1
Priority: -- → P1
Target Milestone: --- → Firefox 72
Attachment #9110633 - Attachment description: Bug 1595842 - import settings wizard from chrome switchers onboarding card CTA → Bug 1595842 - Import settings wizard dynamic triplets onboarding card for chrome switchers
Summary: Invoke import settings wizard from chrome switchers onboarding card CTA → Import settings wizard dynamic triplets onboarding card for chrome switchers
Duplicate of this bug: 1592685

QA Steps:

  1. Create a new firefox profile
  2. In about:config, Set pref trailhead.firstrun.branches to 'join-dynamic_chrome'
  3. Restart and open a new tab
  4. Verify dynamic triplets shown are - Import Settings, Sync and Monitor
  5. Click of 'Import Chrome Data' should trigger 'Import from another browser' wizard

NI Aaron for UI review of added chrome switcher card. As discussed in the patch we should fix image display size together with bug 1598403 as onboardingMessageImage style is shared. Thanks

https://phabricator.services.mozilla.com/D54176#1652272

Flags: needinfo?(abenson)

Attaching screenshot updated with UI feedback.

Attachment #9110910 - Attachment is obsolete: true
Flags: needinfo?(abenson)
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44ec1bb66e7e
Import settings wizard dynamic triplets onboarding card for chrome switchers r=fluent-reviewers,k88hudson,flod
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

I have verified that the “Import Chrome Data”, “Sign in to Sync”, and “Sign Up for Alerts” cards are displayed when enrolled in the “join-dynamic_chrome” branch. I have also verified that the “Import from another browser” wizard is triggered when you click the “Import Chrome Data” button on latest Firefox Nightly 72.0a1 (Build ID: 20191126093448) on Windows 10 x64, macOS 10.15.1, and Ubuntu Linux 18.04 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.