Closed Bug 1596022 Opened 1 year ago Closed 1 year ago

Intermittent browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title preface. -

Categories

(WebExtensions :: Untriaged, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: cbrindusan [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=275959972&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/XMjljRurSJik-d1sS7O9Uw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-11-13T06:09:54.097Z] 06:09:54 INFO - TEST-START | browser/components/extensions/test/browser/browser_ext_windows.js
[task 2019-11-13T06:09:56.637Z] 06:09:56 INFO - TEST-INFO | started process screenshot
[task 2019-11-13T06:09:56.700Z] 06:09:56 INFO - TEST-INFO | screenshot: exit 0
[task 2019-11-13T06:09:56.701Z] 06:09:56 INFO - Buffered messages logged at 06:09:54
[task 2019-11-13T06:09:56.701Z] 06:09:56 INFO - Entering test bound testWindowGetAll
[task 2019-11-13T06:09:56.701Z] 06:09:56 INFO - Extension loaded
[task 2019-11-13T06:09:56.702Z] 06:09:56 INFO - Console message: Warning: attempting to write 40838 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-11-13T06:09:56.702Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect two windows - Expected: 2, Actual: 2 -
[task 2019-11-13T06:09:56.703Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect first window not to be always on top - Expected: false, Actual: false -
[task 2019-11-13T06:09:56.703Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect first window to be always on top - Expected: true, Actual: true -
[task 2019-11-13T06:09:56.703Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect three windows - Expected: 3, Actual: 3 -
[task 2019-11-13T06:09:56.704Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect one window - Expected: 1, Actual: 1 -
[task 2019-11-13T06:09:56.704Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect type to be popup - Expected: popup, Actual: popup -
[task 2019-11-13T06:09:56.705Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect two windows - Expected: 2, Actual: 2 -
[task 2019-11-13T06:09:56.705Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect type to be normal - Expected: normal, Actual: normal -
[task 2019-11-13T06:09:56.705Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect type to be normal - Expected: normal, Actual: normal -
[task 2019-11-13T06:09:56.705Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Expect three windows - Expected: 3, Actual: 3 -
[task 2019-11-13T06:09:56.705Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | getAll -
[task 2019-11-13T06:09:56.706Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | test result correct -
[task 2019-11-13T06:09:56.706Z] 06:09:56 INFO - Leaving test bound testWindowGetAll
[task 2019-11-13T06:09:56.707Z] 06:09:56 INFO - Entering test bound testWindowTitle
[task 2019-11-13T06:09:56.707Z] 06:09:56 INFO - Extension loaded
[task 2019-11-13T06:09:56.708Z] 06:09:56 INFO - Console message: Warning: attempting to write 40918 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-11-13T06:09:56.708Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title preface. -
[task 2019-11-13T06:09:56.709Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title text. -
[task 2019-11-13T06:09:56.709Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title preface before update. -
[task 2019-11-13T06:09:56.710Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title text before update. -
[task 2019-11-13T06:09:56.710Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title preface after update. -
[task 2019-11-13T06:09:56.711Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title text after update. -
[task 2019-11-13T06:09:56.711Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title preface. -
[task 2019-11-13T06:09:56.711Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title text. -
[task 2019-11-13T06:09:56.711Z] 06:09:56 INFO - Buffered messages logged at 06:09:55
[task 2019-11-13T06:09:56.712Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title preface. -
[task 2019-11-13T06:09:56.712Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title text. -
[task 2019-11-13T06:09:56.712Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title preface. -
[task 2019-11-13T06:09:56.713Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title text. -
[task 2019-11-13T06:09:56.713Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title preface before update. -
[task 2019-11-13T06:09:56.713Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title text before update. -
[task 2019-11-13T06:09:56.713Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title preface after update. -
[task 2019-11-13T06:09:56.714Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Window has the expected title text after update. -
[task 2019-11-13T06:09:56.714Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title preface. -
[task 2019-11-13T06:09:56.714Z] 06:09:56 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_windows.js | Updated window has the expected title text. -
[task 2019-11-13T06:09:56.715Z] 06:09:56 INFO - Buffered messages finished
[task 2019-11-13T06:09:56.715Z] 06:09:56 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_windows.js | Created window has the expected title preface. -

OK, I take a look.

Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(sotaro.ikeda.g)

(In reply to Razvan Maries from comment #3)

R/B: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=Windows%2C7%2CShippable%2Copt%2CMochitests%2Ctest-windows7-32-shippable%2Fopt-mochitest-browser-chrome-e10s-5%2CM%28bc5%29&tochange=6965500520e780708c1f1ccae7df92aee5d7d5ef&fromchange=2ea61656154e395c149f6a025cf53f1b0fd2b878&selectedJob=276579196

Sotaro, could you take a look?

"Windows 7 Shippable opt" does not use WebRender. My changes of Bug 1595703 and Bug 1595027 affects only to WebRender enabled environment. Then they should not be related to the regression.

Assignee: sotaro.ikeda.g → nobody

I suspect this was caused by bug 1594457. I think this is fixed by the patch from bug 1595925 but I'm going to give it another day before I close this.

Depends on: 1595925
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.