Closed Bug 1596272 Opened 1 year ago Closed 1 year ago

Intermittent browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - [brand name] - got [brand name] - timed out after 50 tries.

Categories

(Firefox :: Private Browsing, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=276076566&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/eM-nruE6STengUW9IKaqrg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-11-13T21:38:58.959Z] 21:38:58 INFO - TEST-PASS | browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | The window title for about:blank is correct (outside private browsing mode) -
[task 2019-11-13T21:38:58.959Z] 21:38:58 INFO - Buffered messages logged at 21:38:42
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - TEST-PASS | browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | The window title for about:blank detached tab is correct (outside private browsing mode) -
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - Buffered messages logged at 21:38:44
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle_page.html" line: 0}]
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - Buffered messages finished
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - TEST-UNEXPECTED-FAIL | browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - Firefox Nightly, got Firefox Nightly - timed out after 50 tries.
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - Leaving test bound test
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - GECKO(7560) | MEMORY STAT | vsize 2105049MB | vsizeMaxContiguous 65199459MB | residentFast 1001MB | heapAllocated 517MB
[task 2019-11-13T21:38:58.960Z] 21:38:58 INFO - TEST-OK | browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | took 18400ms
[task 2019-11-13T21:38:58.971Z] 21:38:58 INFO - GECKO(7560) | ++DOCSHELL 0000028BEB04A000 == 1 [pid = 9440] [id = {6b6f801f-aa11-422f-b20b-ca47749b1e32}]
[task 2019-11-13T21:38:58.971Z] 21:38:58 INFO - GECKO(7560) | ++DOMWINDOW == 1 (0000028BF1016020) [pid = 9440] [serial = 31] [outer = 0000000000000000]
[task 2019-11-13T21:38:58.971Z] 21:38:58 INFO - GECKO(7560) | ++DOMWINDOW == 2 (0000028BEB0BE000) [pid = 9440] [serial = 32] [outer = 0000028BF1016020]
[task 2019-11-13T21:38:58.990Z] 21:38:58 INFO - checking window state
[task 2019-11-13T21:38:58.990Z] 21:38:58 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-13T21:38:58.990Z] 21:38:58 INFO - TEST-UNEXPECTED-FAIL | browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Found an unexpected browser window at the end of test run -
[task 2019-11-13T21:38:58.992Z] 21:38:58 INFO - GECKO(7560) | must wait for focus

Depends on: 1595925
Summary: Intermittent browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - Firefox Nightly, got Firefox Nightly - timed out after 50 tries. → Intermittent browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - [brand name] - [brand name] - timed out after 50 tries.
Duplicate of this bug: 1597048
Duplicate of this bug: 1596257
Duplicate of this bug: 1596256
Duplicate of this bug: 1595943
Summary: Intermittent browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - [brand name] - [brand name] - timed out after 50 tries. → Intermittent browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Uncaught exception - Window title should be Test title - [brand name] - got [brand name] - timed out after 50 tries.
Regressed by: 1594457

I think this is fixed by the patch from bug 1595925 but I'm going to give it another day or two before I close this.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.