The function which is going to be introduced in bug 1586144 will be confusing. I don't have any ideas to make it sane right now, presumably we should refactor the functionality of
ResizeReflow dividing into two parts, one is for mobile and the other is for desktop since unlike desktop, the outer window size (i.e. browser window) is not normally changed. We should consider a new word instead of just "Resize", I think.