Closed Bug 1596438 Opened 11 months ago Closed 10 months ago

mach build fails on Windows if using upper-case drive letter paths

Categories

(Firefox Build System :: General, defect)

Unspecified
Windows
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: tcampbell, Assigned: rstewart)

References

Details

(Keywords: in-triage)

Attachments

(1 obsolete file)

STR:

  • Go to Windows machine and run the mozilla-build/start-shell.bat script
  • Run mach build with a full path starting each upper-case letter
    • eg. C:/Users/tcampbell/Projects/gecko.dev/mach build

Expected:

  • Firefox build

Actual (in first few minutes of build):

Traceback (most recent call last):
  File "C:/Users/tcampbell/Projects/gecko.dev/obj-x86_64-pc-mingw32/config.status", line 997, in <module>
    config_status(**args)
  File "c:\Users\tcampbell\Projects\gecko.dev\python\mozbuild\mozbuild\config_status.py", line 142, in config_status
    definitions = list(definitions)
  File "c:\Users\tcampbell\Projects\gecko.dev\python\mozbuild\mozbuild\frontend\emitter.py", line 194, in emit
    objs = list(self._emit_libs_derived(contexts))
  File "c:\Users\tcampbell\Projects\gecko.dev\python\mozbuild\mozbuild\frontend\emitter.py", line 228, in _emit_libs_derived
    collection = cls(contexts[root])
KeyError: u'c:/Users/tcampbell/Projects/gecko.dev/obj-x86_64-pc-mingw32/dom/bindings'
Error running mach:

    ['build']

This might just be a wontfix issue, but maybe there is something to be done. I ran into it while trying to set up scripts to call mach directly through the start-shell.bat wrapper. My work around is to use 'cd' in msys environment which normalizes paths enough. (See: https://hg.mozilla.org/integration/autoland/rev/4e3a2ac7a81d )

If I replace with lower-case c:/Users/tcampbell/Projects/gecko.dev/mach build then I can build.

Assignee: nobody → rstewart
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/530a567814d0
mach build fails on Windows if using upper-case drive letter paths r=firefox-build-system-reviewers,chmanchester
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Regressions: 1597957
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b58b9f1e56fc
Backed out changeset 530a567814d0 for causing bug 1597957.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla72 → ---
Attachment #9110109 - Attachment is obsolete: true
Status: REOPENED → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → WONTFIX

The original fix I tried for this didn't work, and after doing some additional investigation I'm finding that we don't generally normcase across the mozbuild codebase. I have low confidence that there's a low-cost fix to this that won't introduce some regression somewhere for Windows developers, and since there's a low-cost workaround (cd'ing), I'm inclined to close as WONTFIX. ¯_(ツ)_/¯

Thanks for the attempt. It seems like we should leave this can of worms alone.

You need to log in before you can comment on or make changes to this bug.