Closed Bug 1596514 Opened 5 months ago Closed 5 months ago

Dynamic Triplets Monitor card and Snippets relying on attachedfxaoauthclients are broken

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

With fix of https://bugzilla.mozilla.org/show_bug.cgi?id=1548404, listAttachedOAuthClients returns data in format
{
id: clientId,
lastAccessedDaysAgo: daysAgo,
}
breaking 'attachedfxaoauthclients' targeting that uses listAttachedOAuthClients method of fxa API regressing 1550720, 1591584
https://github.com/mozilla/activity-stream/blob/master/content-src/asrouter/docs/targeting-attributes.md#attachedfxaoauthclients

Regressed Steps 7 and 8 in https://bugzilla.mozilla.org/show_bug.cgi?id=1591584#c4 as targeting of 'Firefox Monitor' card depends on getting name from attachedfxaoauthclients

https://bugzilla.mozilla.org/show_bug.cgi?id=1547120 exposed FxA client attribute 'name' which is no longer available. NI Markh and MattN to help provide alternate targeting attribute to identify FxA authClient. Thanks!

Regressed by: 1548404
Flags: needinfo?(markh)
Flags: needinfo?(MattN+bmo)

Snippets should use id and lastAccessedDaysAgo instead IMO. The mapping of id to apps can be found at https://docs.telemetry.mozilla.org/datasets/fxa_metrics/attribution.html#service-attribution

Flags: needinfo?(MattN+bmo)

Sorry about this breakage - I had a look in the AS github repo and couldn't find any usage of this API, but I should have tried to reach out regardless.

I haven't got anything to add which MattN hasn't already said - the 'id' is better than the 'name' because the 'name' isn't stable and in some cases can even be edited by the user. We also consider exposing the real and accurate last-accessed time as a privacy concern, so we moved towards only giving you this with accuracy of a day. Please let me know if you need more help here.

Flags: needinfo?(markh)

To detect Monitor specifically, please match on the corresponding OAuth client_id of 802d56ef2a9af9fa.

Assignee: nobody → pdahiya
Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1

Thanks all for clarifying, attached patch to switch targeting to use client_id.

Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28e92798b7fb
Fix monitor dynamic triplets card targeting to use oauth client_id r=andreio
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c55086d8ed5e
Fix monitor dynamic triplets card targeting to use oauth client_id r=andreio,k88hudson

Submitted patch fixing lint failures. Thanks

Flags: needinfo?(pdahiya)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

I downloaded an affected Firefox Nightly build (Build ID:20191117170005) and observed that the "Firefox Monitor" card is still displayed after signing up for alerts.
With the latest Firefox Nightly (Build ID: 20191120234543) the "Firefox Monitor" card is replaced with the next card in the queue but only on a second newtab, due to this issue: Bug 1598292.

@Punam, is this the intended fix for this issue?

Flags: needinfo?(pdahiya)

(In reply to Andreea Cupsa [:acupsa], Experiments QA from comment #13)

I downloaded an affected Firefox Nightly build (Build ID:20191117170005) and observed that the "Firefox Monitor" card is still displayed after signing up for alerts.
With the latest Firefox Nightly (Build ID: 20191120234543) the "Firefox Monitor" card is replaced with the next card in the queue but only on a second newtab, due to this issue: Bug 1598292.

@Punam, is this the intended fix for this issue?

That's correct. This bug fixes hiding Monitor Card when targeting satisfies. Issue around content not getting updated on first preloaded tab opened is being logged as bug 1595074

Flags: needinfo?(pdahiya)

As per the previous comments (Comment 13 and Comment 14) I am marking this issue as verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.