Stop chimera dock icon from bouncing when popup windows open in background

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
General
--
enhancement
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Winnie Lam, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({helpwanted})

unspecified
Camino1.5
PowerPC
Mac OS X
helpwanted

Details

(Reporter)

Description

15 years ago
07-26 build on OS 10.1.5.

1.  Go to a site that opens pop-up windows, e.g. aol.com.  (You may have to
clear your cookies first if you've been to aol.com recently.)
2.  While aol.com is loading, go to another application, e.g. TextEdit.
3.  aol.com loads in the background and opens a pop-up window.  Chimera dock
icon bounces once pop-up window opens.

Actual behavior:  Chimera dock icon bounces once when pop-up window opens.

Expected behavior:  Chimera dock icon should not bounce when the pop-up window
opens.  A bouncing icon implies that the application needs my attention.  A
pop-up window that just opened does not need my attention and should not
distract me from whatever I'm doing with the application in focus, which is
TextEdit in this case.

Comment 1

15 years ago
not clear if it is the OS deciding to bounce due to the new window or our code.
If it is the OS, then I suspect there isn't much we can do about it.
Assignee: saari → pinkerton
(Assignee)

Comment 2

15 years ago
richard, any idea what cocoa is doing here? could it be because we're focusing a
window or something?
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → Chimera1.1

Comment 3

15 years ago
The OS will automatically trigger the user notification when an alert dialog or
sheet appears.  I don't know why it would be doing it for popup windows unless
they are set up so the OS thinks they are some kind of alert dialog.  I'll have
to look at it.

In the meantime, the User Notification controls are in NSApplication, and you
can cancel the user notification every time you create a popup window.  I'll
take a closer look at this later.

Comment 4

15 years ago
Ugh, maybe not.  It would be difficult to cancel the notification without
knowing what this ID number is.  I guess someone needs to talk to Apple and
figure out exactly what kind of window triggers this.
(Assignee)

Comment 5

15 years ago
ohhhhhhhhhhhhhhhhhhh i know what's going on

for every new browser window, in order to make a synchronous load, we enter a
modal loop. that must be what's goofing us here. *sigh* thanks hyatt.

i'll try to get him to tell us why he did that. i'm not expecting a reasonable
answer ;)

Comment 6

15 years ago
Where is this evil modal code?  I've been fighting some modal issues as I track
down why chimera is doing wierd things when one window has a sheet down, and I'd
like to take a look at it.
(Assignee)

Comment 7

15 years ago
it's in BWC, enterModalSession().

Comment 8

15 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
Summary: [RFE] Stop chimera dock icon from bouncing when popup windows open in background → Stop chimera dock icon from bouncing when popup windows open in background
(Assignee)

Comment 9

15 years ago
simon removed the evil modal code, so this bug is now kaput.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.