Closed Bug 1596661 Opened 25 days ago Closed 20 days ago

Add keyed scalars to browser.telemetry

Categories

(WebExtensions :: General, enhancement, P1)

enhancement
Points:
2

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox72 --- fixed

People

(Reporter: adw, Assigned: adw)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

browser.telemetry.registerScalars can create keyed scalars, but there aren't any keyed scalar functions. I'd like to use keyed scalars for a couple of urlbar experiments I'm working on.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/481e4ef0c01d
Add keyed scalars to browser.telemetry r=rpl
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/32eebd872a28
Add keyed scalars to browser.telemetry r=rpl
Status: ASSIGNED → RESOLVED
Closed: 20 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hello,

If this issue can be verified using manual testing, do you mind adding the steps to verify it, other relevant details and the "qe+ verify" flag?
However if this cannot be verified through manual testing or there is no need, please set the "qe- verify" flag so that the issue is no longer present in our resolved bug list.
Thanks!

Flags: needinfo?(adw)

This is a developer feature covered by automated tests and doesn't need manual testing.

Flags: qe-verify-
Flags: needinfo?(adw)
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.