Closed Bug 1596725 Opened 1 year ago Closed 1 year ago

Plugin icon is stretched on the address bar when entering a site with Flash content

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- verified

People

(Reporter: itiel_yn8, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

STR:

  1. Have Flash Player installed
  2. Open http://www.bubbleshooter.net/games/001_bubble_shooter.swf
  3. See the plugin icon in the address bar

AR:
Stretched icon.

ER:
Normal icon.

This regressed between 2019-11-12 to 2019-11-13 but mozregression is unable to bisect further.
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9e3f44e87a1a2be927c7fab135653c6b86b982c9&tochange=88db9bea4580df16dc444668f8c2cddbb3414318

@ Julian, could this address bar icon bug be a regression from your fix for HTMLTooltip bug 1590408? It's in the regression range below.

I see this bug on http://www.zombo.com/. I bisected to this smaller regression range on 2019-11-13:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9e3f44e87a1a2be927c7fab135653c6b86b982c9&tochange=35436d4e7917bf9d9b96a6173201ca001a8ff7bc

I wasn't able to bisect to a smaller regression range due to a mozregression error. I filed mozregression bug 1596823 for that error.

Component: General → Address Bar
Flags: needinfo?(jdescottes)

@ Andrew, could this address bar icon bug be a regression from your fix for SurfaceFormat bug 1594425? It's in the regression range in comment 1.

Flags: needinfo?(aosmond)

could this address bar icon bug be a regression from your fix for HTMLTooltip bug 1590408?

I think it's unlikely, my change only impacts tests or files that are loaded after DevTools are started, which is not part of the STRs.

Flags: needinfo?(jdescottes)

Swapping ni per comment #4. :ntim, can you take a look?

Flags: needinfo?(aosmond) → needinfo?(ntim.bugs)
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6b5e8d8a9ff1
Fix plugin icon and badge appearance. r=Gijs
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Fixed on latest Nightly. Thanks!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.