Closed Bug 159679 Opened 22 years ago Closed 22 years ago

Mozilla should shutdown when all downloads complete

Categories

(SeaMonkey :: UI Design, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 28385

People

(Reporter: cowwoc2020, Assigned: samir_bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.1a+) Gecko/20020703
BuildID:    

We should be able to configure Mozilla such that it will refuse to close down if
there are transfers in progress.

- This should be configurable of course (kinda like what LimeWire has). Mozilla
will either disconnect all connections and close, or wait for all downloads to
complete before allowing the shutdown to complete.

- When waiting for downloads to complete, Mozilla's download manager should be
the only remaining window. Although, we must somehow allow users to abort
shutdown and spawn new windows if they so wish.

- Ideally, Mozilla should remove all completed downloads from the Download
Manager list. This too should be configurable.

Reproducible: Didn't try
> We should be able to configure Mozilla such that it will refuse
> to close down if there are transfers in progress.

not a problem if you have quicklaunch on

[snip]

> - When waiting for downloads to complete, Mozilla's download manager
> should be the only remaining window.

the user can close all browser window and leave the download manager
open (if it is open already).

> [...] Although, we must somehow allow users to abort shutdown and
> spawn new windows if they so wish.

good idea

> - Ideally, Mozilla should remove all completed downloads from the
> Download Manager list. This too should be configurable.

you can delete complete downloads yourself. I like the way it is
(to help me remember what and from where I have downloaded)
this bug is a dup of bug 28385.
I'd still like the option of Mozilla automatically removing completed downloads
from the Download Manager, this is not covered in bug #28385 so it is not a
complete dup.
>...the option of Mozilla automatically removing completed downloads
>from the Download Manager...

it's covered by bug 132755 and/or bug 141794

kail?

Not OS/2 specific
OS: OS/2 → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 28385 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.