Closed Bug 1596820 Opened 1 year ago Closed 11 months ago

Remove use of nsIDocShellTreeItem in nsDocShellLoadState::SetupInheritingPrincipal

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla73
Fission Milestone M6
Tracking Status
firefox73 --- fixed

People

(Reporter: djvj, Assigned: tetsuharu)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

In file docshell/base/nsDocShellLoadState.cpp

Trivial use of ItemType for nsIDocShellTreeItem
Change to use BrowsingContext::Type
Needs change to users.

Type: defect → task
Fission Milestone: --- → M6
Priority: -- → P3
Summary: DummyBug NAME= nsDocShellLoadState::SetupInheritingPrincipal → Remove use of nsIDocShellTreeItem in nsDocShellLoadState::SetupInheritingPrincipal

By these things, I suspect we can replace the type of nsDocShell::mItemType with BrowsingContext::Type safely, but there are some exceptions.

I seem we should add a getter function like nsDocShell::BrowsingContextType() conservatively, or wait to resolve other bugs to remove nsIDocShellTreeItem.

Depends on: 1594285, 1594286
Assignee: nobody → tetsuharu.ohzeki
Status: NEW → ASSIGNED
Attachment #9116126 - Attachment is obsolete: true
Pushed by tetsuharu.ohzeki@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b7f7c1445def
part 1: Implement BrowsingContext::GetType(). r=kmag
https://hg.mozilla.org/integration/autoland/rev/2a509ad44c1c
part 2: Remove use of nsIDocShellTreeItem in nsDocShellLoadState::SetupInheritingPrincipal. r=kmag
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Duplicate of this bug: 1597405
You need to log in before you can comment on or make changes to this bug.